Networking a USB broadband connection


G

Guest

Hi out there. I wonder if anyone knows if it is possible to internet
connection share a USB broadband modem on a network. This modem is gets a
wireless signal from the provider. (For Australian readers, I'm on Telstra's
Next G wireless broadband with a USB desktop modem) I am using a D-Link
802.11g router, connected to the host pc via ethernet. The idea is to connect
to the home wireless network with a laptop to use the internet connection.
When I connect the router (model DI-524) It sets up an Internet Gateway and
forces IE to use it. Of course as there's no modem attached to the WAN port
this gateway is defunct. I am not sure how to direct the browser back to the
USB modem and get ICS to work. Hope I'm making sense.
Thanks for your help!!
 
Ad

Advertisements

S

Steve Winograd [MVP]

Hi out there. I wonder if anyone knows if it is possible to internet
connection share a USB broadband modem on a network. This modem is gets a
wireless signal from the provider. (For Australian readers, I'm on Telstra's
Next G wireless broadband with a USB desktop modem) I am using a D-Link
802.11g router, connected to the host pc via ethernet. The idea is to connect
to the home wireless network with a laptop to use the internet connection.
When I connect the router (model DI-524) It sets up an Internet Gateway and
forces IE to use it. Of course as there's no modem attached to the WAN port
this gateway is defunct. I am not sure how to direct the browser back to the
USB modem and get ICS to work. Hope I'm making sense.
Thanks for your help!!

The key to doing what you want is to use the DI-524 as a wireless
access point only, bypassing its routing capability:

1. If you've enabled Internet Connection Sharing on the host computer,
temporarily disable ICS.

2. Temporarily disable the host computer's USB modem network
connection.

3. Connect the host computer's Ethernet network adapter to a LAN port
on the DI-524. Don't connect anything to the DI-524's WAN port.

4. If the DI-524 has a "use as access point only" configuration
option, select that. If it doesn't have that option, disable the
DI-524's built-in DHCP server.

5. Set the DI-524's LAN IP address to 192.168.0.254 to be compatible
with ICS.

6 Enable the host computer's USB modem network connection.

7. Enable Internet Connection Sharing on the host computer's USB modem
network connection.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com
 
R

RalfG

You don't have to worry about the Internet Gateway too much, but you may
need to configure TCP/IP in the laptop manually or enable Internet
Connection Sharing in the desktop. How you would set up the network depends
on if there are routing functions in the modem or not. If so you can use
those to manage the connections. Either way use the Dlink router just as a
wireless access point. Avoid using the Auto channel select setting on the
router. Pick one of the less busy channels instead.

If the modem cannot do the routing functions you can set up Internet
Connection Sharing on the desktop to handle the internet connection and
TCP/ip settings.

Before configuring ICS on the desktop, change the default address of the
router (LAN button in router config pages) to something other than
192.168.0.1 (the ICS PC will need that address!!) Do keep it in the same
address range and subnet though. Keep track of the new address so that you
can continue to access the router configuration pages.

Most of theWAN settings on the router will become redundant. Set the WAN
connection dialing type in the router to Manual so it doesn't try to connect
to a non-existant modem on the WAN port and disable DNS relay and DHCP. The
laptop should get its IP from the desktop PC. The gateway and DNS settings
for the laptop will be the LAN address of the desktop. Leave the router
wireless security settings disabled until after you have working internet
and LAN connections on the laptop.
 
Ad

Advertisements

S

Steve Winograd [MVP]

Thank you both for your help! I will try this out and see what happens.

You're welcome. Please let the news group know what happens. If there
are any problems, I'm sure we can solve them.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top