.Net CF 2.0 Installation Failure on PDA device


G

Guest

I have a PDA. The model is HP iPAQ h6535. The OS is Microsoft Pocket PC
version 4.20.0 (Build14133). I believe the year of the OS is Microsoft Pocket
PC 2003.

I tried to install .Net Compact Framework 2.0 Redistributable to the PDA,
but the PDA returned a message saying the .Net Compact Framework 2.0
Redistributable cannot be installed on the PDA because this version of the
system does not support .Net Compact Framework 2.0.

On the download page of the redistributable
(http://www.microsoft.com/downloads/...6b-356b-4a2c-857c-e62f50ae9a55&displaylang=en),
The following system requirements were listed:

-- Supported Operating Systems: Windows CE .NET; Windows Mobile 2003
software for Pocket PCs
-- Supported Device Operating Systems: Windows Mobile Software for Pocket PC
2003, Windows Mobile 5.0 for PocketPC and Smartphone, Windows CE .NET 5.0 and
higher.

I thoguht the system requirements for .Net CF 2.0 states that Pocket PC 2003
is supported. Since my PDA's OS is Pocket PC 2003, the installation should
have been successful. However, I could not have the redistributable installed
successfully. Please assist.

Thanks!

Simon.
 
Ad

Advertisements

Ad

Advertisements

W

William LaMartin

I have an HP iPAQ h4350 Pocket PC with Windows CE version 4.20.0 (build
m13252).

When I tried to install the Compact Framework (CF 2.0 ) with the device in
its cradle, I got a message to the effect that I had the wrong setup
program--whatever that meant. I decided to outsmart the installation and
using Visual Studio 2005 wrote a simple Pocket PC Windows application with
nothing but a command button. I then used the device to debug the
application supposing that in the process the CF 2.0 would be installed.
Instead I received the message that I needed a newer version of ActiveSync.
So I downloaded ActiveSync 4.1. Once this was installed, I could used the
device to debug my simple application and in the process the CF 2.0 was
installed to the device.

In addition, I sent a friend an application I had written for the Pocket PC
to be installed and told him he would need to first install the CF 2.0 on
the device. When he tried that with the device in its cradle, he got the
same error message as I had first gotten. He also had Visual Studio 2005
installed on his computer and hence also the CF 2.0. He uninstalled this
from his computer, then again tried to install the CF 2.0 with the device
cradled, and everything worked fine.

Perhaps one of these methods will work for you.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top