More compact flash issues


G

Guest

Ok so I've scoured this newsgroup and read every post with CF or compact
flash in it. I hate when people ask the same stupid questions too, but I'm
at a total loss. Anyhow here goes.

I'm a total XPe newbie, so I suspect this is 100% user error. Anyhow problem:

I've got a tiny little fanless machine with no peripherals which I'm trying
to get to boot XPe off of a flash drive. I have 2 different CF drives, each
512. I've tried the same on both:

Use fdisk to delete existing partitions
Use fdisk to create 2 partitions, primary is 320, secondary is 168
Format both drives with FAT
run BootPrep on the primary
Copy my build over

Both drives ... same issue: "disk error".

I used a hex editor to crack open the MBR of the flash drive and I found
that as one of the three error messages in there. I suspect this is an MBR
issue but its all undocumented so I can't start flipping bits. Anyone have
any idea how I can get this fixed? At this point I dont know if the CF's are
even bootable or whatnot. I don't have a clear debugging path here and I am
really out of my domain of knowledge. I would like to try and make the
damned things DOS bootable as an acid test but apparently its nigh impossible
to make anything but a floppy disk DOS bootable.
 
Ad

Advertisements

M

Mark Kraft

Feral,

Make sure the primary partition is set to Active.


--
Mark Kraft
Design Engineer
Lehigh Electric Products Co.
Tel: 610-395-3386
Fax: 610-395-7735
email: (e-mail address removed)
website: www.lehighdim.com
 
G

Guest

Yeap did that, sorry for not mentioning it.

Still no real progress, I keep thinking if I can just get it to boot to dos
I'll know its not a hardware issue. Unfortunately everything I find that
will make a dos boot disk ... intends to make one out of a floppy. Anyone
have any idea how in this day and age I'd make something dos bootable? I
have no floppy drives on any machine here ... even if I did I doubt I could
find any floppy media if I had to.

I dont think I'm even getting to NTLDR.
 
S

Sean Liming \(eMVP\)

1. XPe is not going to be able to see more than one partition on a removable
devices unless it is ID as fixed. Partitioning the CF card is okay, but XPe
will only see one partition.It can boot from the active partition, but it
will not see the other.
2. There have been some issues where a CF card will not boot XPe because of
some wierd reason. Sometimes the same model and manufacture will not work. I
created a flash list (http://www.seanliming.com/flashhelp.html) to provide
information on developers who have successfully booted XPe on a specific CF
card.
3. If you want to add DOS to the CF card to see if it will boot, you might
need a different FORMAT utility: http://www.bootdisk.com/.

Are you preparing (Fdisk, format, Bootprep) the CF cards in an IDE to CF
adapter under DOS?

Regards,

Sean Liming
www.sjjmicro.com / www.seanliming.com
XP Embedded Book Author - XP Embedded Advanced, XP Embedded Supplemental
Toolkit
 
S

Stuart Langley

Are you preparing the card connected to an IDE to CF adapter on your target
machine?

From memory Disk Error related to translating CHS values to lookup the
active partition to load the OS. The fixed disk bit will not effect the
initial boot before ntldr starts up.

First step should always to be able to boot into DOS prompt on the CF before
running bootprep. Use a Win98 floppy boot disk to prepare you CF card and
ensure that it will boot into DOS before trying anything else.

If you do not have a floppy connection on your target hardware, there are
various USB based Win98 boot disks laying around that can be used to acheive
the same. Google for them.

Regards,

Stuart
 
Ad

Advertisements

G

Guest

Thank you guys for the responses. I figured it out and this is the followup
so maybe if anyone else runs into this they can figure it out. Ultimately it
was a whole lot of things that ended up misdirecting me.

#1. I have no floppy drive ... this made the whole "making a floppy" part
of every instruction set ... worthless to me. I worked around this by
downloading Bart's bootable CD. Once I did that I was able to run format /s
on the CF and could then boot to dos with it.

#2. I had an IDE card reader (this is mandatory, either this or get USB
support on your boot disk), but I also had a hard drive in the same system.
This was loading the CF up as the second device, the hard drive first. So
when I was running BootPrep it was with a /dD flag. This was incorrect. The
CF card ALWAYS has to be the C device. This was what really ended up killing
me


So anyhow:
- Get either a boot disk or boot CD.
- Get either an IDE CF writer, or get USB support on your boot disk/CD
- FDISK the CF (partition/activate), then format /s it. At this point you
should be able to boot from it, if not you have hardware issues.
- Reformat it.
- Run BootPrep, but make sure this CF is the C device so that you can run
Bootprep /dC. I just uplugged the harddrive in my system to force this to
happen.

Hope that helps someone through the gotcha's that nailed me. Anyhow again
thanks everyone who replied, now I get to figure out how to actually make a
bootable build ... so far little luck in that department ... seems like this
is going to be a long uphill battle :).
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top