MMC could not create the snap-in



When attempting to access several admin tasks via the MMC console, the above
error occurs. The snap-ins (non-third party, standard come-with-vista, not
part of the 2003 admin pack) are:

Event Viewer
Task Manager

MMC snap-ins that do work:
Computer management
Local security policy
Print Management

What I have attempted to solve the problem:
Remove and re-add the snap-ins for Event View and Task Manager in MMC.
Result: "MMC cannot initialize the snap-in. Name: Task Schedule.
Same results with a different CLSID for Event Viewer
I have confirmed that the registry keys do exist and the System and
Administrator have full control on them. They appear fully populated.

Ensure I have the minimal version of the .Net framework for MMC 3.0.
Result: In my Microsoft.NET\Framework directory, I have
The v.2.0.50727 is supposed to be what MMC 3.0 needs to run.

Verify services are running:
Event viewer service is running as is task scheduler. I am unable to stop
task scheduler's service and event viewer has a dependency on it.

Appropriate administrator permissions
I am the sole administrator on the machine and have disabled UAC until
problem is resolved so all of my prompts are elevated.

Run the system file repair tool at the command prompt.
No notice of errors, no apparent fix after completion.

Attempt to run repair from Vista installation DVD:
Vista is installed on a RAID striped controller. I was able to install to
it, but Vista installer does not see it in installed versions of vista.
Repair is not an option. Have tried to run various raid drivers (and I can
see my c: drive from the PE command prompt, but nothing has detected my Vista

Run the registration command script for the Server 2003 Admin pack:
Created the .cmd files suggested from the MS KB article. No effect.

I've taken just about every suggestion I can take from the net on how to fix
this problem and have come up short every time. I am about ready to create a
support incident with MS, but hate to spend $59 when the problem is with the
core OS admin functions and I haven't messed with any third party software or
snap-ins that would have messed with this. I am also reluctant to reinstall
Vista after spending so much time getting my system stable and running
optimally with the exception of this problem. Without being able to view the
event log, I do not know if I have impending problems with my system. I
consider the problem pretty serious. Is there anyone from Microsoft who can


I have the very same problem here. MMC and Task Scheduler. I run a vista
Ultimate SP1 x64.

I have the exact same problem and under SP1 32bit. Either appeared
after PC Wizard 2008 or Firefox3, which stopped working for no
apparent reason. PC WIzard had its own version or subset of the Evenrt
Viewer and it was reporting some rather oddly dated events (more than
18 months old, longer than I owned machine) and I have installed Vista
Business clean twice. I also do not wish to reinstall to return this
functionality, but I am stumped

I have tried all the things you describe, but no luck. (Even more, I
dare say) I spend more of my life getting applications or OS's working
and stable, than actually uisng the system.



If you were to post direct to an MS group, explaining your problem, you
might get a formative resonse, rather than posting to another group that
leaches off the MS groups and posts a none explicit explanation


I dont know who or why everyone is going through so much hassle with
this problem and so much work to fix it try this ::::

In *Computer Management*, verify that you are in the console for the
remote computer.

*TYPE IN ::Services - and click on it*
*select ::pROPERTIES*
*start up type ::AUTOMATIC*
*then click ::START*
*then click ::APPLY *
*then click ::OK *
*That should do it - if not ill eat my hat =*
*ohh wait - sorry i dont own a hat!!! lol ohh well *
*if you got a problem w/ it just e -mail me @ "(e-mail address removed)"*

Well my case it help some of the stuff but my task still has MCC warning for others getting closer........

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question