microphone not recognised in XP



I have the same problem as posted by other users below for which no solution
has been found. Basically, my pc won't recognise any microphone i plug into
it. I have updated drivers for sound card but still cannot record sound.

Interestingly, when I go to control panel "sounds and audio
devices">"sounds and audio devices properties" and click on the "audio" tab,
the "advanced" button is greyed out under "sound recording". Something wrong

Can anyone help please?

previous similar posts from other users:
If you haven't gotten updated XP drivers for the sound card, that could
certainly be the problem.

This just amazes me when people do this -- ask for help because they don't
know what's wrong, they get an answer, but have their own line of logic they
want to follow, so whatever is suggested can't be right.

Until you've gotten the correct drivers for the sound card, there's really
no sense in looking elsewhere. Windows ME drivers won't work with XP, so
chances are you've got some default drivers loaded that don't have all of
the features.

And no, there aren't drivers for the microphone, unless it's USB or
something else that would need drivers. A basic mic that plugs into a sound
card doesn't need drivers.

And just to point out the obvious, have you gone into the recording
properties and made sure the mic is selected as the recording device? Much
of the time it defaults to line in, and you can usually only have one
recording device at a time.

If you're looking at the "playback" for your soundcard, and the mic isn't
muted, that doesn't really do much good, because sound doesn't come out of
the mic.

David Candy

No it is driver dependent if Advanced is greyed out or not. It usually is. Have ypou set the mic volume in Record mode (the vol applet has several modes - Playback is the default). Options - Properties.


are you saying it is the driver for the sound card that's at fault?

Mic volume in record is set to highest, and mic is selected (tick in box).

Master volume control (in options, properties, record) is also greyed out
(but in options, properties, playback it is NOT greyed out) - does this all
throw any further light on possible problem?

ps. desktop speakers work fine.

Drew Tognola


Your sound card probably doesn't support 'Automatic Gain Control', which are
the options shown when you select "Advanced'.



Try this step by step. Hope this help.

1. Open Volume Control.
2. See if there is an entry of "Microphone". If not then click Options -
Properties - check mark Microphone.
3. If there is an entry of Microphone - click Advanced button under
4. Is there some settings called "Mic Boost". if yes, then test your
MicroPhone by checking and unchecking these options.
5. Also, click Option - Properties - select option Recording - check the
Microphone. click Ok. Click Select option under Microphone.

If all these settings doesn't help then:

1. Open Sound and Audio Devices Properties by right-clicking on Volume Icon
from Taskbar and click "Adjust Audio Properties" (you can also open it
through Control Panel).
2. Click the Voice tab and select an appropriate device under "Voice

Hope this information helps, let us know!

Open Advanced Control of your Volume Control. As you already checked
everything. Try this one. Is there advanced butto


in the voice tab in voice recording there is nothing to select - in fact,
the advanced button is greyed out.

is this something to do with the problem?


generally anything to do with sound recording is greyed out. playback is fine
(buttons not greyed out and speakers play sound).

have tried to update drivers for sound card (I think i have onboard VIA
AC'97 audio (wave) whatever that means), but device manager says I have the
most up to date drivers already installed.


That means you have not properly installed the Sound Drivers or they are not
fully compatible with current OS. You need your Motherboard CD (If inbuilt
Audio) to reinstall/Update the Drivers or you can also goto the manufacturer
web-site to download the latest drivers. CD will be the easiest way. Prefer
Sound Drivers for Windows XP only.

Let us know!


I have now done this. Went to the gigabyte website and downloaded the latest
version of the driver for the onboard VIA 686 sound for my GA-7DXE
motherboard. The driver version was a later one (version 5.20b) than the one
I had.

Guess what? The problem is still there, and all the buttons that were greyed
out with the earlier driver (version 5.10) are still greyed out - nothing has
changed whatsoever!

This is a real puzzle!


You are here in this new group that means you realy want to sort out the
problem by yourself. So try your best before you call someone.

One more thing that I can suggest you that is:

Uninstall or Roll Back Previous Drivers.
Then Reinstall the newer one.
Furthermore, instead of installing the latest drivers by running SETUP
wizard of Audio Drivers try upgrading the drivers. Also, use "Install from a
list or specific location (Advanced) option.

In your next post, tell me:

Have you checked the Device Manager properly? Is there any yellow exlamation
sign or red cross sign in front of any device?
Have you tried Microphone before and was it working?
Is your sound card is inbuilt or have a seprate PCI card?
Before giving up try System Restore.
Is there near by a computer? So, if you can put that card and check out if
the problem is in Sound Card.

Let us know!


Hello hd
I may be able to help, so if you cannot get a resolution today/tonight I
will look at your post tomorrow and see, then contact you here.
Have to go out all night.


Right, here's what's happened:

Device manager shows all devices working fine. Sound card is onboard sound
not PCI. Tried two different mics, one known to previously work on another

Instead of updating driver for audio, this time uninstalled driver. This
caused pc to restart. On restarting, pc automatically installed driver.
Driver installed was an earlier version (2001) than the two (2003, 2005) that
did not work.

With this old driver installed, tried mic and belive it or not, it worked.
So did the other mic. However: Buttons in audio options were still greyed
out, and sound quality from speakers appeared to be inferior than before.

Decided to take a chance and chose to update driver again. Decided to do
this manually (as you suggested) by choosing from a list (of the other two).
Chose the 2003 driver.

Result: mic still worked, buttons still greyed out (but probably who cares),
and sound quality from speakers back to normal.

Taken me seven hours and several grey hairs, but things seem to at least be
working. I'm off for a pint.

Thanks for your help - uninstalling the driver completely seems to have been
the answer to solving it all.


Hi hd
Just got home - well done. You went further than I was going to suggest -
but it is always an amazement to me how many times a driver problem happens
and the latest all singing and dancing version does not work - yet going
back to an original one which has been uninstalled then installed, does
I trust you got well, if not completely smashed.
Thank you for telling us

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads