Mac OS 9 and Win2k Services for Macintosh


G

Guest

I'm experience a weird problem recently, my Mac OS 9 users can't connec to a
Win2k Server running services for Macintosh. They see the server from the
chooser after they type in user and and password, click ok and the screen
would froze right there. They did not get to the screen where they can select
a share.
This is only happen to Mac OS 9, Mac OS X user can mount the share without
any problem.
Is there a limit to how large a share volume for Mac OS 9? The share volume
I have is very big, it's over 130 GB.
I don't know if this problem related to my server would crash very quite
often now but I could not see anything in the log. If I disable File Server
for Macitosh then my server would not crash any more. Any advice?
 
Ad

Advertisements

B

Brian D. McGrew

I'm am having the exact same problem (and how ironic that I come into the
newsgroup and this is the first post that I read).

The share on my server is 100GB. All of my stuff was working fine up until
three weeks ago when the server crashed and I had to rebuild it from
scratch. Same drive configuration and same share sizes but no all of the
sudden, Mac OS9 is hosed.

I'm very puzzled here and in (a bit of) trouble becuase it's my lead
engineers who use Mac, so no Mac, no engineering :)

TIA,

-brian
 
M

Marimuthu [msft]

Hi ,

There is an Apple file share limitaion for OS 9, the KB aticle from Apple
web site is
http://docs.info.apple.com/article.html?artnum=15460

That describes that each folder should contains 65536 files. If you have
more than taht then you need to load balance the share.

Some times this may be the issue with Antivirus.

What is the Antivirus Version you are using? If you are using Symantec
Antivirus 9.0 then please follow the below KB article
http://support.microsoft.com/default.aspx?scid=kb;en-us;883409

--
Regards,
Marimuthu.P

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This posting is provided "AS IS" with no warranties, and confers no rights.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
W

William Smith

Brian D. McGrew said:
I'm am having the exact same problem (and how ironic that I come into the
newsgroup and this is the first post that I read).

The share on my server is 100GB. All of my stuff was working fine up until
three weeks ago when the server crashed and I had to rebuild it from
scratch. Same drive configuration and same share sizes but no all of the
sudden, Mac OS9 is hosed.

I'm very puzzled here and in (a bit of) trouble becuase it's my lead
engineers who use Mac, so no Mac, no engineering :)
Hi Brian!

Your Mac volume's file database may be corrupt and need to be rebuilt.
I'll quote the following snippet that I've saved. It's been a great
resource but unfortunately I'm unable to give an attribution as to the
author:

============
If you copy or move files to a Macintosh volume on a Windows NT server,
the Mac clients on the network might not be able to see these files,
even though the PC shares can. This problem, which happens with multiple
versions of the Mac OS, lies with the volume index file that tells the
Mac clients which files are available on the networkshare. You can
intentionally corrupt this index file and force NT to rebuild it so that
the Mac clients can see the files you copied or moved.

If the problem exists in a volume that is part of a directory (e.g.,
d:\public), use the following command syntax at the command prompt:
dir > D:\PUBLIC:AFP_IdIndex

If you're rebuilding a root drive share (e.g., d:\), use the following
command syntax:
dir > D:\:AFP_IDIndex

If your path includes spaces, you must enclose the path in quotes. So,
if the Services for Macintosh (SFM) directory in the above example was
I:\Mac Volume, you would use the following command syntax:
dir > "I:\Mac Volume":AFP_IdIndex

Note that this command will intentionally corrupt the Macintosh volume
index. When you stop and restart SFM, the corruption forces NT to
immediately rebuild the volume index file. If you see an Access Denied
error message, files might be open on the volume or PC users might be
accessing the shared directory. Disable all programs and file sharing to
prevent this error.

After NT finishes rebuilding the index, the OS will log an event in NT
Event Viewer. If the volume is large, it might take several minutes
before the Macintosh client can see all volumes and files. Avoid
stopping the SFM service during this time.
============

Hope this helps! bill

William M. Smith
(Microsoft Interop MVP)
 
G

Guest

We were having this problem, too, and thanks to the info below found that it
was caused by the upgrade to Symantec's Antivirus 9 product. We made the
correction per the kb article, and our Macs can now access the server. Thank
you so much for mentioning this.

Cyndi
 
P

Patrick Sears [MSFT]

You should also notice that the version of AFP used by File Services for
Macintosh has a maximum volume size of 2GB.

--

Patrick Sears
Windows Networking

This posting is provided "AS IS" with no warranties, and confers no rights.
Please do not send email directly to this alias. This alias is for newsgroup
purposes only.
 
Ad

Advertisements

J

Jim Seifert [MSFT]

No need for this registry edit with Windows 2000 and Windows 2003 servers.
The number of files, number of volumes and volume size can vary with client
OS versions. Older clients, pre 7.5 I believe (but maybe AFP specific) will
not see volumes over 2G.
 
Ad

Advertisements

G

Guest

Hello Derrick,

i've look in the forum for an other problem, can i tell you a question about
licensing?
In our firm we have got a license problem with connecting Mac's in aWin2k
Server.
The Server will give the Macs a timelimit License (CAL).
After the limit i must license the Macs with new CALs, not so for
microsoftbased Computer. They became a productiv CAL.
Do you have same problems?
Or can you tell me something about our License with Mac's/Win2k to solve my
problem

Thank you ...

Best regards.
Daniel
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top