Local printer is not show up on Terminal client connection.


G

Guest

Hi,
I have win2000 server running terminal services in Application mode. I have
laptop and local HP 4000 Leaser printer installed. But when I connect to
terminal server using Remote desktop client or Terminal client my local
printer is not showup there. On terminal server serivce configuration I put
check mark on map local printer but didn't help.
 
Ad

Advertisements

V

Vera Noest [MVP]

Have you checked the EventLog on the Terminal Server?

If you see an Event 1111, indicating that redirection of the
printer failed, because the driver was not found, then you probably
have a mismatch in driver names.
If that is the case, you can solve it by creating a custom
ntprintsubs.inf file to map the driver names.
Documented here:

239088 - Windows 2000 Terminal Services Server Logs Events 1111,
1105, and 1106
http://support.microsoft.com/?kbid=239088

If you don't see any Event at all regarding redirection of the
printer, then check the local printer port.
HP has a habit of creating a custom printer port, often called
DOT4. If that's the case, you have to make a registry change on you
client to get the printer port redirected.
Details here:

302361 - Printers That Use Ports That Do Not Begin With COM, LPT,
or USB Are Not Redirected in a Remote Desktop or Terminal Services
Session
http://support.microsoft.com/?kbid=302361
_________________________________________________________
Vera Noest
MCSE, CCEA, Microsoft MVP - Terminal Server
http://hem.fyristorg.com/vera/IT
___ please respond in newsgroup, NOT by private email ___

=?Utf-8?B?TWl0ZXNoIFBhdGVs?=
 
G

Guest

Hi,
I do not have that Event error on event log! Is there any settings so that
my local printer will show up on terminal session. I am using Remote desktop
client to connect to W2k terminal server.
Thanks
 
V

Vera Noest [MVP]

And did you check the local printer port on the laptop to see if it
is a DOT4 port?

I assume that you have already checked in Terminal Services
Configuration that redirection of local printers is allowed (which
is the default) and that the rdp client is configured to redirect
the local printer?

_________________________________________________________
Vera Noest
MCSE, CCEA, Microsoft MVP - Terminal Server
http://hem.fyristorg.com/vera/IT
___ please respond in newsgroup, NOT by private email ___

=?Utf-8?B?TWl0ZXNoIFBhdGVs?=
 
Ad

Advertisements

Joined
Mar 4, 2012
Messages
7
Reaction score
0
HI,
If the printer does not show on the server you need to install
print drivers on server,It would be good if the print driver is the same version as is on the client. If it still does not work you can try this: 1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following key in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type FilterQueueType, and then press ENTER.
5. On the Edit menu, click Modify.
6. Type FFFFFFFF, and then click OK.
This enables all ports on the client to be redirected.



I know from personal experience that this does not work very well so I recommend some other printing software solution. several of them are on the market but one that works great is TSPrint from http://remotedesktopprinter.com/ hope it helps


 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top