Keyboard doesn't work


A

Andreas M

Hello
I'm fairly new at XPe.
I'm trying to make an image for a gaming kiosk. I have made a devices.pmq
file with tap.exe on the target machine and imported this in my design. Just
to see it boot and work before adding custom shell and gaming software etc I
have added touchscreen drivers, SATA controller, Hardware Control Panel and
Command Shell and Minlogon.
When I boot this image and gone through FBA I get the command prompt but I
can't type anything. I tried adding Standard 101/102 key PS/2 Keyboard
component, but still the same.
I then removed the components Command Shell and Minlogon and added Exploer
Shell and Windows (Logon Standard). But still can't type in the run field
(touchscreen works).
The keyboards Num Lock button is lit, and the keyboard works in the BIOS and
with Win XP Pro installed.
I have all the components thats needed for keyboard I could think of.
Class Installer - Keyboards
CoDevice Installer - Keyboards
Device: Keyboard
English Language Support
Keyboard and Mouse Control Panel
Keyboard Class Driver
Keyboard: United States English
all Language English (countryname)
Standard 101/102-Key or MS natural PS/2 Keyboard

Anyone have any idea what I'm doing wrong?

Best regards
Andreas
 
Ad

Advertisements

G

Gokul

What kind of keyboard you are using? is it usb keyboard if so did you check
HID components are added?

regards
 
S

Stephen Bashford

Hello
I'm fairly new at XPe.
I'm trying to make an image for a gaming kiosk. I have made a devices.pmq
file with tap.exe on the target machine and imported this in my design.
Just
to see it boot and work before adding custom shell and gaming software
etc I
have added touchscreen drivers, SATA controller, Hardware Control Panel
and
Command Shell and Minlogon.
When I boot this image and gone through FBA I get the command prompt but
I
can't type anything. I tried adding Standard 101/102 key PS/2 Keyboard
component, but still the same.
I then removed the components Command Shell and Minlogon and added
Exploer
Shell and Windows (Logon Standard). But still can't type in the run field
(touchscreen works).
The keyboards Num Lock button is lit, and the keyboard works in the BIOS
and with Win XP Pro installed.

Do you have a mouse working? I had a similar problem last week. When I
looked in Device Manager I saw that they keyboard was a unknown device and
it wouldn't work.

The Num Lock was lit but wouldn't toggle.

The problem for me was that alhough TAP had identified the keyboard
controller my hardware actually required a PS/2 y-cable. I had simply
plugged the keyboard into the PS/2 socket which worked fine for XP Pro,
not for XPe though.

Connect keyboard with the y-cable and all was well.

Good luck,

Stephen
 
Ad

Advertisements

A

Andreas M

I have a PS/2 keyboard.

I solved the problem now.
I started a new image but instead of directly importing the devices.pmq file
in target designer I imported it in Component designer and made a component
and imported into the database and then added that component into target
designer. Same hardware and same file and now the keyboard works.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top