Kaspersky conflict


floppybootstomp

sugar 'n spikes
Moderator
Joined
Mar 5, 2002
Messages
20,227
Reaction score
1,728
Here’s the brief spec of my main machine:

speccy13-02-17.JPG



The motherboard came with software that allows me to update all motherboard drivers and any of the utilities that came with it. I haven’t installed any of the utilities but have regularly used the driver update facility which has worked flawlessly.

I installed Kaspersky Antivirus software – freebie via Barclays Bank Business account – 64 days ago. I know this as Kaspersky told me I had 301 days left on the licence they gave me.

I had not used the MSI driver update facility since installing Kasperskys AV.

Today I opened the MSI software and noted there were around five drivers that needed updating and the first one I chose to update was the network (Killer) drivers. MSI advised me shut down any AV software so I opened Kaspersky, opened settings and switched the protection button to off.

Then I went ahead with updating the LAN driver and saw a progress bar as the old version was uninstalled. Then nothing happened. I opened task manager and saw Kaspersky was enabled so figured Kaspersky was stopping the driver installation, seeing it as a threat.

Windows 10 had already flashed a warning window asking whether I wished to go ahead and let this software make changes to my system and I agreed. Kaspersky gave no showing of any blocking activity.

After waiting a good ten minutes and not seeing any progress I closed down the driver installation using task manager and then noticed I could not access online as of course my old LAN drivers had been uninstalled.

So I went to install a restore point in Windows 10 but Kaspersky wouldn’t let me do that either, it blocked access to one folder, it told me. Next step was to load original motherboard drivers from the DVD that came with the board but nope, Kaspersky wouldn’t let me do that either.

Next I uninstalled Kaspersky, loaded the original LAN drivers from the DVD, gained online access and updated the LAN drivers online via the MSI update facility. And then all the other MSI drivers, Intel chipset etc.

So am I missing something here? Is accessing Kasperskys settings and switching it to ‘off’ not disabling it? Is there another way to disable it without uninstalling the whole thing?

I did leave Kasperskys registration details during the uninstall process with a view to reinstalling it but I’m not sure now whether I want to install it again. Any advice appreciated.

On a seperate note, Kaspersky has quarantined one file so far. I know what that file is and I know for sure it’s not a virus or Malware but it’s no longer important to me so I’ve left it quarantined. At least that’s better than BitDefender which when I had it installed took it upon itself to obliterate several files completely with no chance of recovery. Again I knew those files were not malicious.
 
Ad

Advertisements

Ian

Administrator
Joined
Feb 23, 2002
Messages
19,579
Reaction score
1,304
The way I'd disable Kaspersky is to right click the tray Icon and select "pause protection" - that will turn of all of the components. I'm using Kaspersky Internet Security, so it may be slightly different.

On mine, there are options to turn the AV checker "off", but that doesn't disable system protection, application control, firewall etc... I suspect if I disabled the AV and tried to run your drive app, it would be the "system protection" module that would catch it (which would still be enabled).

Were there any other modules you could disable in KAV?
 

floppybootstomp

sugar 'n spikes
Moderator
Joined
Mar 5, 2002
Messages
20,227
Reaction score
1,728
Were there any other modules you could disable in KAV?

See my question 'Am I missing something here?' ;) The short answer is - I don't know. I had assumed the button I switched to Off disabled the whole thing, I can't even remember for sure what exactly it said.

I do know that I haven't encountered this problem with any former AV programs I've used - which have all been the freebie ones - and am not sure whether this makes Kaspersky better or worse. Quite annoying whatever the case.
 

Ian

Administrator
Joined
Feb 23, 2002
Messages
19,579
Reaction score
1,304
Yeah it does sound like a bit of a pain, but at least it's working (albeit a false positive). That said, you would expect Kaspersky to prompt or alert, rather than outright block!

I'd stick with it and explore the options and see if that pause option in there in the tray menu :). I've had few problems with Kaspersky and I've been using their products for many years. Not perfect, but the best I've used so far.
 

muckshifter

I'm not weird, I'm a limited edition.
Moderator
Joined
Mar 5, 2002
Messages
25,601
Reaction score
1,104
I've not had any problems with Kaspersky either, that is not to say one will never have a problem ... it has been noted from some vendors that their AV can sometime be overzealous in its protection.

Just call it Mother. :)
 

nivrip

Yorkshire Cruncher
Joined
Mar 21, 2007
Messages
9,474
Reaction score
1,822
I've used Kaspersky through Barclays for a number of years and not had any problems. :)

When certain downloads have suggested switching off AV I've simply gone into Settings and switched the button to Off, same as you did. This has then allowed the download to occur without trouble. A couple of times I forgot to switch Kaspersky off when downloading and there were problems, in that the download failed. Switching it Off then allowed the download.
 
Ad

Advertisements

floppybootstomp

sugar 'n spikes
Moderator
Joined
Mar 5, 2002
Messages
20,227
Reaction score
1,728
Thanks for the feedback folks. I've noted all your comments and have now reinstalled Kaspersky.

I'll see what happens - and will be taking notes - the next time the MSI motherboard drivers are due for an update.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top