Inserting USB Storage Devices Restarts XP


G

Guest

I have an IBM Thinkpad T41.

Every time I insert any sort of USB storage device, I get a blue screen with
a message on it (it says something about accessing memory, but it's so fast,
I can never capture it).

The storage device can be a USB memory stick (I've tried PNY Attache' and
Minidisk), a compact Flash card reader, and a Nikon Coolpix 4300 camera)

I don't get the same behavior when I insert any other sort of USB device
(such as a mouse or a keyboard.)

I have updated the BIOS and the Embedded Controller Program. I have
downloaded and installed all Windows Updates.

I have uninstalled and allowed Windows XP to detect and reinstall the USB
devices in device manager.

Any idea of what could be wrong?
 
Ad

Advertisements

N

Nathan McNulty

Nope, not a clue :)

Just kidding, I can't say exactly what is wrong, but I can suggest a few
things. Here is a link to all of the updates for your product (I know
you said you updated them already, but just in case):
http://www-1.ibm.com/support/dlsear...IBM+Thinkpad+T41&dc=&submit.x=100&submit.y=15

Also, have you tried each device in each USB port and seen if they cause
different results in different ports? It could be that one of the ports
is faulty. A good workaround may be to get a USB 2.0 Hub, and connect
that to the good USB port and then connect everything to the hub. That
is a suggestion if nothing else works.

I would also run that PC Doctor provided for your Thinkpad and finally,
I would uninstall your embedded controller software and reinstall them
to see if that helps.
 
Ad

Advertisements

G

Guest

Yep... got all the updates.

Yep... tried a USB hub, tried only plugging in 1 usb device at a time...
tried both slots.... no love.

I ran PC Doctor provided

But I didn't uninstall & reinstall my embedded controller software. I will
try that & let you know how it goes.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top