import csv truncation


M

MikeC

When importing to a table from a .csv, data is truncated. I want to avoid
the truncation. I have imported the .csv file to a new table, then deleted
the records & changed the fields that are giving me a problem to 'memo'.
Then I try to import the .csv to the table I just created, but the fields are
still truncated. What am I missing?

Thanks,
Mike
 
Ad

Advertisements

K

Ken Snell [MVP]

You'll likely need to use an import specification to tell ACCESS that the
..csv file's column is a memo data type. This works with the TransferText
action, but not with a manual import process.

You create an import specification by manually beginning the import process
(via File | Export). When you're in the wizard window, click the Advanced
button at bottom left. In the new window, you'll see all the settings you
can specify. Enter all the information. Click Save As button and save them
as a specification (name it whatever you want, e.g., "MyEImportSpec", for
example). Click OK button to return to the main window of the wizard. Then
click Cancel button to cancel the rest of the import.

Now go to your TransferText code and add the name of the specification to
the appopriate argument position.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top