How to force drive letters


M

Matthew Reed

I setup an ext2 partition on a hard drive, and changed a few partitions
around. Now, I can't get my drive letters the way I want them. My drives
look like this:

C Drive: |--- Fat32 ---|--- ext2 ---|
D Drive: |--- Fat32 ---|--- Fat32 ---|--- Fat32 ---|--- linux swap ---|
E Drive: |--- Fat32 ---|--- Fat32 ---|

These should have drive letters as follows:

C Drive: |--- C ---|--- ext2 ---|
D Drive: |--- D ---|--- F ---|--- G ---|--- linux swap ---|
E Drive: |--- E ---|--- H ---|

C, D, E work. H works. F gives an error, and G is mapped to my K: drive. If
I boot to Win98 or DOS, all drive letters work as expected. It's only in XP
that I can't get them to work. If I run partition magic, it shows the ext2
partion as F:.

So - how do I get Windows to not see the ext2 partition as my F: drive, and
let me assign F to where I want it? Likewise G:?
 
D

_DD

So - how do I get Windows to not see the ext2 partition as my F: drive, and
let me assign F to where I want it? Likewise G:?
Did you try Disk Management? You can get there via:
R-Click 'My computer' on desktop
Select Manage
The click 'Disk Management' (duh)

R-Click on the displayed graphic for the partition in question and
'Change Drive Letter and Path'

Reboot, just to make sure.
 
Ad

Advertisements

M

Matthew Reed

Did you try Disk Management? You can get there via:
R-Click 'My computer' on desktop
Select Manage
The click 'Disk Management' (duh)

R-Click on the displayed graphic for the partition in question and
'Change Drive Letter and Path'

Reboot, just to make sure.
Disk management was my first stop. If I try to assign the letter F: to the
partition, it's not in the list of available drives. In explorer I see F
because Windows maps it to my ext2 partition. In disk management, I can't do
anything with the ext2 partition, not even control the drive letter assigned
to it.

I can see the ext2 partition in explorer, it shows it as Local Disk (F:).
The drive that would normally be mapped to F: is mapped to J:, so I can
access it, but not as the drive letter I want it to be.

I'm guessing this is stored in the registry somewhere - can I change it in
the registry?
 
U

Uwe Sieber

Matthew said:
Disk management was my first stop. If I try to assign the letter F: to the
partition, it's not in the list of available drives. In explorer I see F
because Windows maps it to my ext2 partition. In disk management, I can't do
anything with the ext2 partition, not even control the drive letter assigned
to it.

Open a command prompt, enter
mountvol F: /d
to delete the drive letter association to you ext2 partition.


Greetings from Germany

Uwe
 
Ad

Advertisements

M

Matthew Reed

Uwe Sieber said:
Open a command prompt, enter
mountvol F: /d
to delete the drive letter association to you ext2 partition.


Greetings from Germany

Uwe
It worked great, thanks!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top