Fujitsu fi-4860c, SCSI scanner


G

Goran Zec

We have a Fujitsu fi-4860c scanner connected to SCSI interface (Adaptec SCSI
card). It worked correctly, than stopped. The scanner scans the page, but
it doesn't transfer to the application. The TWAIN driver seems to freeze
doing something in the kernel, since the application that invoked it hangs
hard and doesn't come back.

I tried:
1.) reinstalling WinXP SP2, Fujitsu's TWAIN drivers 9.xx; it worked for a
short time (beats me why), than stopped again.
2.) changing SCSI settings; installing the freshest SCSI BIOS for the SCSI
card
3.) earlier Fujitsu's TWAIN drivers (8.xx), with ASPI. That doesn't work
either.

The part that baffles me is that it worked for a short while after reinstall
- I shut down automatic updates, so the system didn't change in the
meanwhile.

Did anyone see anything like this? Any help is appreciated.
 
Ad

Advertisements

D

degrub

Make sure you delete all the files in the \twain , \twain32 , and \twunk
directories that relate to your scanner.
 
Ad

Advertisements

D

Danny

Hi Goran,

sorry about the late response, I would have replied right away if I saw
this post earlier.. but, I was on business travel the last2 weeks.

I'm sure that Fujitsu support already helped you resolve the
communication problems.. but just incase they didn't:

This is a typical event where the scanner is identified properly by
windows (device manager ID's Fujitsu fi-4860CEdj... but, when
attempting a scan via a twain application (like scandall21 or Acrobat 7
std) the hopper would:

1. raise up
2. feed the first sheet
but the Twain32 progress bar would hang at 0 percent.

This happens when the Adaptec scsi card 19160, 29160, etc.. has the
incorrect device drivers loaded. This is a bit more difficult to
isolate since Device manager shows everything is properly installed and
running.. including the scanner with the STI Twain 9.x..

The way to fix your problems :

1. From device manager, right click on the adaptec scsi card

2. update drivers

3. when the wizzard prompts you for what you'd like to do ( update
automatically or Install from a list...) MAKE SURE YOU SELECT THE
"install from a list:

4.Then select :don't search" ...

5. the next window will show several device drivers for the Adaptec
SCSI card.

you may see some which list (Microsoft) with the scsi card... even
though it's named the same adpu160m.sys or inf...

If your OS has more than one device driver for a peripheral, Window's
will default to the microsoft version device driver- unless told to
point to another.

The lockup problem in my experience occurs only when the adaptec
hardware has the Microsoft device drivers. (driver details will also
confirm manufacturer of the inf and sys files.)

simply select the Adaptec signed driver. (if you don't see it, you can
download it from the adaptec website or try using the generic driver
that might be listed in the wizzard)

This should resolve the problem.. if not call me anytime at
408-746-7096 direct or 408-203-6057 cell.

Hope it helps~

Danny Ha
Fujitsu Computer Products of America, Inc.
(e-mail address removed)

- i
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top