Folders and files missing in network (windows XP Prof)


Tobias Beiss


i have got a strange problem concerning my network browsing between two
desktop PCs and my laptop.
First of all I have to declare my situation:
All mentioned PCs or lptops are running Windows Xp Professional with SP2
and the latest patches. On all computers the simple filesharing is
turned off.

I've got a desktop PC at work, in a NT4 domain (so there's no AD).
My laptop is also joined to that domain, but I use it at home too.
At home I have a simple TCP/IP network without domain.

On my Laptop I created a local user with the same name and Login like
the user on my desktop at home. Also on the laptop, there is an
administrator account which is equal to my domain account. With this
structure I can log into my laptop using the standard share f$.

Now I have a directory, which i mirrored (copied) to my laptop, so that
I can do some work on it and later synchronize the data, using
FREECOMMANDER, to my desktop or the other way round (editding data on PC
and synchronizing with laptop)

All I mentioned before was already working with my old laptop (Toshiba).
But as this one broke down, I had to buy a new one (Asus).

Right from the start with the Asus I encountered Problems seeing files
or folders on my two PCs (desktop at home and at work) in the network.
In many folders there were files missing, which actually on the PC
itself were there (could be seen). The other way round, specific files
(or in the mirrored folders the same files) could not be seen, when I
was browsing the laptop from one of the desktops. I thought, that it was
a problem of the OEM Asus XP Installation, so I formatted the harddisk
and installed my own Windows XP Professional coming from an unattended
CD including SP2, I have here at work. This CD doesn't make much more
than the standard Windows CD, but setting time and region, setting the
administrator account, turning the desktop and start menu tothe
classical view, disabling simple file sharing and doing some registry
tweaks concerning amongst others the nerving bubble tips, search
function and trash bin confirmations.

After that installation I thougt, my problems were solved but I was at a
fault. I still didn't see the same files and folders like before. I am
now shure it has something to do with owning and the rights on files,
because I see (or don't see) different files while using the local
administrator account, the account from home or my domain account.
When I look into the properties of the files or folders I see and
compare them to files or folders I can't see, I do not see a difference:
same owners, same permissions, same effective rights...

Till today I tried a lot of things to solve this problem, but nothing
worked. To modify the rights on the files I

- made a specific share (in order to not use the standard administrative
share f$ - who knows what problem that could make)
- modified the right and owner of this share (set owner to different
users, modified rights to everyone as full access, specific users have
full access, etc.)
- mounted the share as a network drive using different users (domain
account, local user, local administrator)
- inherited permissions
- set specific permissions
- moved the files to another pc, removed all permitted users and set
them new, then moved the files back
- switched to simple file sharing

nothing of this worked. I am now on a point where I don't know any
further solution. The strange thing is, that on my old Toshiba all
worked without problems (also Win XP Prof SP2).
What else can I do. The files are from different sources and have been
made by different users. Maybe there is any tool with that I can clean
the ACLs of the files and kind of reset them to zero or something like
My last possible solution would be to install windows new from the
scratch and not using the unattended CD, but a standard CD. But I would
like to avoid that because it is a lot of work.

I would be glad, if I recieved some help here. Unfortunately I didn't
get a response in the german newsgroup till now.

Greets from Erlangen

Tobias Beiss

An additional thing:
When I insert the folder name (of a folder I can't see in the explorer)
I can access it without any problems. But after leaving it, I still
don't see in the folder above...

Tobias Beiss

Yeah, I found it!


that was the point...

"NtfsDisable8dot3NameCreation"=dword:00000001 --> this silly little line
with the RegKey set to one cost me 2 weeks of work and bad feelings...

WIth ths key set, in folders with names larger than eight characters,
there are randomly files or objects missing, while the folder is brosed
over the network... They cannont be seen, but you have access, when
typing the name into the adress bar (as I described before)

Well, lets hope this post helps any other poor Win user, which has the
same problems I had... If you save two weeks in the future, be happy...

greets tob

Daniel Prince

Tobias Beiss said:
"NtfsDisable8dot3NameCreation"=dword:00000001 --> this silly little line
with the RegKey set to one cost me 2 weeks of work and bad feelings...

What value should it have? Should it be 00000000?

Tobias Beiss

Yes, I set it to "0" in the registry editor on the computer I wanted to
access, after that it worked

Greets Tobias

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question