Folder view settings not being saved


G

Guest

I have two seperate icons. One for My Documents and one to go directly to my
C: drive. When I open up my Documents folder, edit the view to be "Medium
Icons", then close it, then open up my C: drive, it has reverted from "List"
option to "Medium Icons" setting. If I then change my C: drive to the "List"
view option, close it, then open my Documents folder, it's also taken the C:
drive's options and converted it to "List". In the folder options I have it
checked to "remember each folder's view settings". I also, just for giggles,
enabled the "launch folders in a seperate process" with no luck. Quite
annoying, any suggestions?
 
Ad

Advertisements

G

Guest

You might try going to Control Panel (Classic View) > Folder Options and, on
the View tab, choose Reset Folders (Apply>OK). This clears your remembered
folders in the registry, which aren't being remembered, obviously, and starts
things from scratch.

Dean
 
G

Guest

Chad,

As per your advice. I did the regedit, however had to do work-around and
actually create the .reg file since Mozilla displays the info.. then applied
it. Problem still exists.

Chad Harris said:
TJW--

I cannot speak with certainty for Vista, but the rule of thumb in XP is
this:

XP and probably Vista is designed to "remember" 400 folder settings. This
can be adjusted up to any level--I have a lot more folders on XP and would
on Vista but I save time by shortcutting to the XP desktop and then only
copying or moving folders I really need.

I'm going to give you the regedit automatically done for you from Kelly
Theirot who MSFT gave the MVP of the Year Award too in 2004 for her tireless
and spectacular work on the XP newsgroups and I look forward to Kelly's
Vista site when it comes.

Increase folder setting size to 8000
http://www.kellys-korner-xp.com/regs_edits/bags8000.reg

Click it>yes to accept>yes to apply in dialogue box.

I'll also show you the regedit manually.

Open your registry and find the key below.
Create a new DWORD value called "BagMRU Size" and set it to the number of
folders that Windows should save settings for (e.g. 1000).

Repeat the step for the same value at
[HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam].

Restart Windows for the change to take effect.





(Default) REG_SZ (value not set)
BagMRU Size REG_DWORD 0x000003E8 (1000)

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell



Registry Settings
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell]
Value Name: BagMRU Size
Data Type: REG_DWORD (DWORD Value)
Value Data: Default = 400 folders



Kelly's XP (Explore all the links on the sides--useful utilities and info)
http://www.kellys-korner-xp.com/xp.htm

A to Z
http://www.kellys-korner-xp.com/xp_abc.htm

Tweaks (Automatic regedits and VB scripts--Totally Safe)
http://www.kellys-korner-xp.com/xp_tweaks.htm

About Kelly
www.microsoft.com/windowsxp/expertzone/meetexperts/theriot.mspx

Enjoy--should work in Vista.

CH







What I want you to try is to adapt this to Vista. I'm not on a Vista box
boot right now, I'm on that primitive back in the day OS called XP but see
if this will work for Vista. I haven't had to apply it yet.


TJW said:
I have two seperate icons. One for My Documents and one to go directly to
my
C: drive. When I open up my Documents folder, edit the view to be "Medium
Icons", then close it, then open up my C: drive, it has reverted from
"List"
option to "Medium Icons" setting. If I then change my C: drive to the
"List"
view option, close it, then open my Documents folder, it's also taken the
C:
drive's options and converted it to "List". In the folder options I have
it
checked to "remember each folder's view settings". I also, just for
giggles,
enabled the "launch folders in a seperate process" with no luck. Quite
annoying, any suggestions?
 
D

Doug

I had a similar problem with Vista remembering the folder's size. I also
tried Chad's Kelly trick which seemed to work for a while and then reverted
to default size. It may sound crazy but I UNCHECKED ( remember each folder
setting ) and it has been fine ever since.
Using RC2 5744.

Doug
 
D

dean-dean

Hi TJW,

If the following doesn't work, I don't know what will.

Based on this article:

http://www.kellys-korner-xp.com/xp_common_tasks.htm

Solution One, in the article, is probably your only recourse, which involves
deleting two registry keys. However, the registry keys that Keith Miller,
the author of the article, refers to are for Windows XP, and not Vista. The
locations for these keys have changed in Vista (as have many others, which
is why I cringed a little at Chad Harris's post, since there are really no
up-to-date sites, yet, that I know of, that deal with the changes in Vista's
registry, as they are only
accurate for XP). (By the way, Vista is set up to "remember" 5000 folders,
so no tweaking is
really necessary. Windows XP SP2, too, increased the Bag value to 5000,
from 400 in XP SP1).

Anyway, by deleting these two keys, you will start with a clean slate, and
all remembered folder settings in Windows Explorer for view state, window
position, sort order, column information, folder type, toolbar toggles, and
search result views will be lost, and reset to the correct defaults, just so
you know what to expect; but any corruption, which indeed does happen, will
also be
deleted. The keys in Vista are:


HKEY_CURRENT_USER\Software\Classes\Local
Settings\Software\Microsoft\Windows\Shell\BagMRU
(right-click on BagMRU and choose delete)

HKEY_CURRENT_USER\Software\Classes\Local
Settings\Software\Microsoft\Windows\Shell\Bags
(right-click on Bags and choose delete)

Log off and log back on to Windows to re-create the keys (done
automatically), and start anew.

I recently had to do this myself, on my computer, because the folder type
templates had gone haywire, making the Windows and System 32 folders
Music-type folders, which resulted in inappropriate Explorer Bar tasks (with
no way to change it, since they're special folders), all my New Folders
defaulted to Picture-type folders, and folder views kept getting scrambled
from views I had chosen: all these
being among other things that were driving me crazy. This fixed things
nicely, for me, and now special folders show the right tasks, and regular
folders use the All Items template, all with more logical default columns,
as well...

Hope this helps,
Dean
 
Ad

Advertisements

S

Synapse Syndrome

dean-dean said:
Hi TJW,

If the following doesn't work, I don't know what will.

Based on this article:

http://www.kellys-korner-xp.com/xp_common_tasks.htm

Solution One, in the article, is probably your only recourse, which
involves
deleting two registry keys. However, the registry keys that Keith Miller,
the author of the article, refers to are for Windows XP, and not Vista.
The
locations for these keys have changed in Vista (as have many others, which
is why I cringed a little at Chad Harris's post, since there are really no
up-to-date sites, yet, that I know of, that deal with the changes in
Vista's registry, as they are only
accurate for XP). (By the way, Vista is set up to "remember" 5000
folders, so no tweaking is
really necessary. Windows XP SP2, too, increased the Bag value to 5000,
from 400 in XP SP1).

Anyway, by deleting these two keys, you will start with a clean slate, and
all remembered folder settings in Windows Explorer for view state, window
position, sort order, column information, folder type, toolbar toggles,
and
search result views will be lost, and reset to the correct defaults, just
so
you know what to expect; but any corruption, which indeed does happen,
will also be
deleted. The keys in Vista are:


HKEY_CURRENT_USER\Software\Classes\Local
Settings\Software\Microsoft\Windows\Shell\BagMRU
(right-click on BagMRU and choose delete)

HKEY_CURRENT_USER\Software\Classes\Local
Settings\Software\Microsoft\Windows\Shell\Bags
(right-click on Bags and choose delete)

Log off and log back on to Windows to re-create the keys (done
automatically), and start anew.

I recently had to do this myself, on my computer, because the folder type
templates had gone haywire, making the Windows and System 32 folders
Music-type folders, which resulted in inappropriate Explorer Bar tasks
(with no way to change it, since they're special folders), all my New
Folders defaulted to Picture-type folders, and folder views kept getting
scrambled from views I had chosen: all these
being among other things that were driving me crazy. This fixed things
nicely, for me, and now special folders show the right tasks, and regular
folders use the All Items template, all with more logical default columns,
as well...
This was always one of the most annoying things about XP for me, and it's
very disappointing to see Vista having the same problem.

They should have changed the system so that the data for view types is saved
in the folder's desktop.ini file rather than the registry. I can't see how
that could be a problem even considering network shares, and MacOSX seems to
do this.

ss.
 
G

Guest

TJW said:
I have two seperate icons. One for My Documents and one to go directly to my
C: drive. When I open up my Documents folder, edit the view to be "Medium
Icons", then close it, then open up my C: drive, it has reverted from "List"
option to "Medium Icons" setting. If I then change my C: drive to the "List"
view option, close it, then open my Documents folder, it's also taken the C:
drive's options and converted it to "List". In the folder options I have it
checked to "remember each folder's view settings". I also, just for giggles,
enabled the "launch folders in a seperate process" with no luck. Quite
annoying, any suggestions?
just had this happen to me too, most annoying.
considering a reinstall at the weekend and see if that clears it.
 
G

Guest

Hi there,
This is also what I'm experiencing. It's so annoying - and also happens to
the preview pane you can activate. Any solution someone?
 
Ad

Advertisements

Joined
May 16, 2013
Messages
7
Reaction score
0
Solution for: Folder View Settings aren't saved (also - Quick Launch Dissapear after shutdown) :

In any folder, click "Tools" (in the Menu bar) > click "Folder Options", click "View" tab, in "Advanced Settings" list, find and check mark "Remember each folder's view settings" (also, ensure that "Do not cache Thumbnails" is not checked). Then,set the view of any folder as you want, then go to the "View" tab in "Folder Options", and click the "Apply to all folders" button. If this wont solve your problem, then use this:

click "Start > Run" and enter these 2 commands one by one-

Code:
REG ADD "HKEY_Current_User\software\microsoft\windows\currentversion\policies\explorer" /v "NoSaveSettings" /t REG_SZ /d "0" /f


REG ADD "HKEY_Local_Machine\software\microsoft\windows\currentversion\policies\explorer" /v "NoSaveSettings" /t REG_SZ /d "0" /f


Then restart the computer.

after windows logon, ensure that the Quick Launch Toolbar is ticked via right click on taskbar>toolbar>tick quick launch.</br>
Restart the computer a second time!!! That's all.

Thanks so much to Correz and Rainna.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top