Excel "file is already open"


J

John McFadden

Whenever I open a '.xls' workbook from outside Excel
(such as from Windows Explorer), Excel indicates that the
file is already open - although, once I click OK, I seem
to be able to work with the file normally. The same file
will open fine from within Excel. I am using Excel 97 on
an XP-Home machine.

Can you explain why I may be getting this message, and
how I might correct for it?
 
Ad

Advertisements

T

Tom Ogilvy

with excel open, go to tools=>Options=>General and make sure Ignore Other
Applications is not checked.

if that doesn't help with the opening, close excel, go to the windows start
menu and select run (it is in the right column of choices at the bottom on
my version of win -xp)

enter

Excel.Exe /regserver

and click OK.

This will reset Excel's registry settings.


Regards,
Tom Ogilvy
 
J

John McFadden

-----Original Message-----
with excel open, go to tools=>Options=>General and make sure Ignore Other
Applications is not checked.

if that doesn't help with the opening, close excel, go to the windows start
menu and select run (it is in the right column of choices at the bottom on
my version of win -xp)

enter

Excel.Exe /regserver

and click OK.

This will reset Excel's registry settings.


Regards,
Tom Ogilvy





.
Thanks, Tom,

EXCEL /REGSERVER did the trick.

John
 
Joined
Nov 16, 2008
Messages
1
Reaction score
0
Hi,

The information from that link from Debra Dalgleish was immediately helpful. I was having the exact same problem as John when using Excel 97 on an XP home computer. Thank you, PCReview, for keeping this post/thread readable to the public for the past 5+ years.

-Kri' sis
 
Ad

Advertisements

Joined
May 24, 2017
Messages
1
Reaction score
0
with excel open, go to tools=>Options=>General and make sure Ignore Other
Applications is not checked.

if that doesn't help with the opening, close excel, go to the windows start
menu and select run (it is in the right column of choices at the bottom on
my version of win -xp)

enter

Excel.Exe /regserver

and click OK.

This will reset Excel's registry settings.


Regards,
Tom Ogilvy


John McFadden <[email protected]> wrote in message
news:[email protected]
> Whenever I open a '.xls' workbook from outside Excel
> (such as from Windows Explorer), Excel indicates that the
> file is already open - although, once I click OK, I seem
> to be able to work with the file normally. The same file
> will open fine from within Excel. I am using Excel 97 on
> an XP-Home machine.
>
> Can you explain why I may be getting this message, and
> how I might correct for it?


resetting Excel registry worked for me, thanks

enter

Excel.Exe /regserver

and click OK.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top