Driver doesn't load at bootup


G

grc

At system bootup time,
XP Event Log reports:

Event Type: Error
Event Source: Workstation
Description:
Could not load MRxSmb device driver.

This is followed by:
Could not load RDR device driver.

How do I repair this situation?
Are there updated driver versions?
Might they be corrupted? If so how
do I fix them?
Thanx for any help.
 
Ad

Advertisements

Joined
Jun 5, 2005
Messages
1
Reaction score
0
I had the same problem last night, and I think that it was because the file mrxsmb.sys file in Windows\System32\Drivers directory was corrupted. There is a backup of the file inside of sp2.cab or possibly inside of Windows\ServicePackFiles\i386

Hope that helps.
 
Joined
Jul 18, 2005
Messages
1
Reaction score
0
hi i have the exactly same problem. I also have BSOD like IRQL is not less or equal, and pfn list corrupt. Did you solve teh problem yet, if yes how do u solve it?
 
Joined
Jan 4, 2007
Messages
1
Reaction score
0
Workstation Service Terminated With Service-specific Error 2250

First of all, 1000 thanks to Trefenwynd for the sanity-saving advice about that crummy little "mrxsmb.sys" file missing from the XP C:\Windows\System32\Drivers folder.
I have been working on this nightmare for over 20 hours and 2 days now, and was just about to give up and call MS Tech Support (never a pleasant task) when I stumbled across this solution which hit the nail precisely on its head.
I actually joined the Forum just to say thanks and alert everybody to a closely-related problem which ultimately brought me here:
For totally unknown reasons (except maybe uninstalling Norton SystemWorks and Personal Firewall, prior to the installation of Windows OneCare Live) the Windows Workstation Service suddenly just would not start; it had been working perfectly up to that time.
I searched the MS Knowledge Base as well as the Internet, double-checked all the pertinent Registry entries and the corresponding files (save for the one mentioned above) with a known-good computer, and could find nothing wrong or out-of-place until I ran across this post.
Anyway, anybody having this sort of problem should also check out this article:

http://www.jasonhartman.net/2005/01/problem-starting-server-and.html

The part about the accounting software may or may not apply to your case; if it doesn't, just scroll on down for a variety of solutions.
The main thing is that between the two of these articles you should be able to get back up and running in no time; it's outrageous that there isn't more technical information in the MS Knowledge Base about this situation, as obviously many, many people are experiencing the problem, with virtually no resources available to help solve it.
I just hope this helps others as much as it helped me.
Good luck!
 
Last edited:
Joined
Dec 5, 2007
Messages
1
Reaction score
0
I just registered to say thanks! I have been fighting this exact problem for a while now. I found that the mrxsmb.sys file was missing from the c:/windows/system32/drivers folder. I copied the file form a working machine to the one that was missing in the correct folder. Everything worked great after a reboot.

Once again many thanks!
 
Ad

Advertisements

Joined
Oct 6, 2011
Messages
1
Reaction score
0
I had downloaded and ran "MIcrosoft Safety Scanner" v. 1.0.3001, which successfully removed a virus from my PC. However, I could not browse my network afterwards. To make the story short I followed the advice given by Trefenwynd and found the file mrxsmb.sys was removed from my system32/drivers folder.

I just wanted to thank for the advice and warn anyone who used Microsoft Safety Scanner some side-effects of using the software.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top