DEP and Windows XP SP3


F

FSN Tech

Data Execution Prevention - Microsoft Windows "To help protect your computer,
Windows has closed this program. Name: Remote Desktop Connection Publisher:
Microsoft Corporation." These are the updates that were done recently- KB
updates - 952287, 952954, 938464, 950762, 951698, 951376-v2, 950974, 951376,
951066 and 946648 which after the updates this message occurred. If the
message is not closed, RDP can be used normally. I have gone into the
Advanced tab under Data Execution to select the option to have DEP not be
used on RDP - rebooted the laptop and still have the issue. What is the next
step to correct this issue?
 
N

nass

FSN Tech said:
Data Execution Prevention - Microsoft Windows "To help protect your computer,
Windows has closed this program. Name: Remote Desktop Connection Publisher:
Microsoft Corporation." These are the updates that were done recently- KB
updates - 952287, 952954, 938464, 950762, 951698, 951376-v2, 950974, 951376,
951066 and 946648 which after the updates this message occurred. If the
message is not closed, RDP can be used normally. I have gone into the
Advanced tab under Data Execution to select the option to have DEP not be
used on RDP - rebooted the laptop and still have the issue. What is the next
step to correct this issue?

1- Click Start >> Control Panel >>Select System
2- On System Properties Click the Advanced tab.
In the Performance region select Settings
3- Click the Data Execute tab in the dialog box that opens
4- Select Turn on DEP for all programs and services except for those I select
then Click Add.
5- The open dialog box will open. Browse and select your application.
6- Click Open
7- Click [Apply] Then Click [Ok]
Reboot your machine and try to open any program/application.

How to Turn DEP OFF:
http://support.microsoft.com/kb/875352

Edit the Boot.ini to include<noexecute=AlwaysOff>:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=AlwaysOff /fastdetect

More info about the DEP:
Description of the Date Execution Prevention feature in SP2:
http://support.microsoft.com/default.aspx?kbid=875352&product=windowsxpsp2

Use the ShellExView to monitor in real time what cuaing the DEP issue:
http://www.nirsoft.net/utils/shexview.html

What is DEP? and how to disable it:
http://msdn.microsoft.com/en-us/library/ms791539(printer).aspx
Turn the DEP OFF:
http://technet.microsoft.com/en-us/library/cc700810.aspx
http://www.techsupportforum.com/microsoft-support/windows-xp-support/94002-dep-prevents-opening-windows-explorer.html

HTH,
nass
 
Ad

Advertisements

F

FSN Tech

I did the steps listed below.
1- Click Start >> Control Panel >>Select System
2- On System Properties Click the Advanced tab.
In the Performance region select Settings
3- Click the Data Execute tab in the dialog box that opens
4- Select Turn on DEP for all programs and services except for those I select
then Click Add.
5- The open dialog box will open. Browse and select your application.
6- Click Open
7- Click [Apply] Then Click [Ok]
Reboot your machine and try to open any program/application.

After the reboot, my client still had the pop-up message for DEP. I chose
the Remote Desktop Connection box that was already listed below so I did not
have to add as per the instructions listed above. I have not yet implemented
the turn off in the boot.ini file. I believe one of the Windows updates has
caused this issue, I just do not know for sure which one at this point since
the problem did not occur before the Windows updates this month.

Thank you for your information.

FSN Tech


nass said:
FSN Tech said:
Data Execution Prevention - Microsoft Windows "To help protect your computer,
Windows has closed this program. Name: Remote Desktop Connection Publisher:
Microsoft Corporation." These are the updates that were done recently- KB
updates - 952287, 952954, 938464, 950762, 951698, 951376-v2, 950974, 951376,
951066 and 946648 which after the updates this message occurred. If the
message is not closed, RDP can be used normally. I have gone into the
Advanced tab under Data Execution to select the option to have DEP not be
used on RDP - rebooted the laptop and still have the issue. What is the next
step to correct this issue?

1- Click Start >> Control Panel >>Select System
2- On System Properties Click the Advanced tab.
In the Performance region select Settings
3- Click the Data Execute tab in the dialog box that opens
4- Select Turn on DEP for all programs and services except for those I select
then Click Add.
5- The open dialog box will open. Browse and select your application.
6- Click Open
7- Click [Apply] Then Click [Ok]
Reboot your machine and try to open any program/application.

How to Turn DEP OFF:
http://support.microsoft.com/kb/875352

Edit the Boot.ini to include<noexecute=AlwaysOff>:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=AlwaysOff /fastdetect

More info about the DEP:
Description of the Date Execution Prevention feature in SP2:
http://support.microsoft.com/default.aspx?kbid=875352&product=windowsxpsp2

Use the ShellExView to monitor in real time what cuaing the DEP issue:
http://www.nirsoft.net/utils/shexview.html

What is DEP? and how to disable it:
http://msdn.microsoft.com/en-us/library/ms791539(printer).aspx
Turn the DEP OFF:
http://technet.microsoft.com/en-us/library/cc700810.aspx
http://www.techsupportforum.com/microsoft-support/windows-xp-support/94002-dep-prevents-opening-windows-explorer.html

HTH,
nass
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Windows XP SP3 9
Windows XP SP3 4
Windows XP SP3? 9
Windows xp sp3 5
Windows XP SP3? 2
WIndows XP SP3? 12
Windows XP SP3 2
Windows XP SP3 13

Top