Defrag & Chkdsk


G

Guest

I use a PC running Win 2K pro, my problem is that I can not run CHKDSK.
If I set CHKDSK from within Windows, when windows restarts, chkdsk fails to
run - does not have exclusive access to the HDD.

Stated PC in 'safe made with command prompt', can now run CHKDSK, but NOT
with /F switch - does not have exclusive access to the HDD.

Any suggestions as to what may be going wrong?
How can I identufy what processes are accessing HDD.

Thanks
 
Ad

Advertisements

D

David Webb

It sounds like Chkdsk is being bypassed during startup. If so, the message
you're receiving is normal (assuming it's the C drive). Once Windows loads, you
cannot have exclusive access to this drive.

Try this:
Open a command prompt window and execute these commands:

To restore the system to normal behavior:
chkntfs /d

To check the status of the drive:
chkntfs c:

If it reports a DIRTY drive, do this to schedule a manual chkdsk at the next
startup:
chkntfs /c c:

Then close this window and then restart the system. If chkdsk is successful
after restart then run defrag after Windows loads.

If chkntfs reports the drive is NOT dirty simply close the window and try to
defrag
again.

Here's detailed info on this utility:
CHKNTFS.EXE: What You Can Use It For
http://support.microsoft.com/default.aspx?scid=kb;en-us;160963&Product=win2000
 
G

Guest

Thanks for response.

Done everything in your reply, but can not get chkdsk to run.
When PC is started up, part way through boot up process black screen appears
& message 'can't open volume for direct access' normal boot process then
automatically continues.

Thanks again
 
G

Guest

Thanks for that.
Did manage to run chkdsk from recovery console.
Still won't run when scheduled from windows though, very odd - still think
another process is posibly using the HDD.

Thanks again
 
D

David Webb

You're welcome...and thanks for the feedback.

Here's a few long-shots: You might want to be sure that all temp files are
purged from the system and user cache locations and in case you are networked,
disable any shared folders. If my memory still serves me correctly, installed
Norton HDD utilities could be the culprits.

Good luck!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top