Crystal Reports report updating problem on Windows Server 2003 w/.NET 1.1


Doug Lim

I have an ASP.NET application that I've developed using Visual Studio
..NET 2003 and I'm making use of Crystal Reports for .NET that's
included to return reports back to the visitor's web browser in PDF

Up to this point, I've had no problems with the application in both
the development environment (local workstation with Windows 2K) and
deployed in production (on a Windows 2003 Server) both with .NET
Framework 1.1.

This past week, I made a modification to one of the Crystal Reports
report definition files and updated both the development and
production web server. The updated report works as expected reflecting
the recent report change in the development environment, but the
output from that report in the production environment appears as
though the report has not been updated on the production server.

I have tried both of:
- updating the production environment by just replacing the Crystal
Reports .RPT file in the web application directory on the production
web server.
- completely uninstalling the web application through Add/Remove
Programs through the production web server's control panel and
reinstalling with an updated MSI web application deployment package.

I have gone as far as stopping/restarting the World Wide Web
Publishing Service. I have not tried completely shutting down and
restarting the entire box.

Has anyone else run into this problem where it appears that an
outdated Crystal Reports .RPT file appears to be getting stuck in a
cache somewhere? Any suggestions on troubleshooting and fixing this
are greatly appreciated.

Thanks in advance.


I'm having the exact same issue... Any assistance from the MS moderators
would be very much appreciated!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question