CF Ram Reg EWF "Incorrect function"



Maybe a solution for some, more than a question.

My configuration:
- Primary IDE
-- Master: harddisk (temporary)
-- Slave: CD-ROM drive (temporary)
- Secondary IDE:
-- Master: CF (set to non-removable)
- Floppy: drive connected (temporary), no disk present.

The final configuration will only have the CF; no HD, CD or floppy.
There's no support for Floppy or CD-ROM in the XPe target.

I let FBA run on harddisk, made the registry changes as per the docs,
rebooted: "ewfmgr c:" showed a working RAM REG EWF.

Then I copied everything from HD to CF, disconnected the HD, and rebooted
from CF. "ewfmgr C:" now said "Incorrect function".

I rebooted once more to be sure, checked the registry settings (all still
OK), but it still said "Incorrect function".

Then I disconnected the CD-ROM and floppy drives and tried once more: EWF
was now working.

There was a CD in the drive, but there's no CD-ROM support in the target,
nor floppy disk support, yet somehow one of these still interfered with
I suspect it's the CD, and that the problem will disappear if it is
connected after the CF in the PM-PS-SM-SS sequence (as secondary slave for

For this target I only need the CF, but I can imagine that it would cause
problems iif I had needed the CD-ROM too: the hardware only allows me to
connect drives to the primary channel, and the CF is fixed as secondary
master (on the mainboard).

Slobodan Brcin \(eMVP\)


If all that you said is true then I have no idea what could be the cause.

First could you tell us what EWF revision do you use (QFE update number or

Is this the error that you see, or something else?
Failed getting protected volume configuration with error 1.
Incorrect function.

I'll assume that you have filled registry correctly for Reg RAM EWF since
EWF worked on HDD.

My only guess about your problem would be:

1. CF was present during the FBA on HDD and got assigned volume letter.
2. You copied content of HDD to CF.
3. You booted from CF.

After that:
C: would be HDD that is not under EWF protection.
D: would be CF that is protected by EWF.

try to determine OS volume letter and then type something like:
ewfmgr D:

I know that you said that you have removed HDD, but have you checked volume
letter on which OS files reside?



try to determine OS volume letter and then type something like:
ewfmgr D:

I'm now running an endurance test of the completed target on my test
platform, I can't try anything out without losing two days, but I'm pretty
certain that it was C: all the time.
AFAIR, the CF wasn't connected during FBA.

Thinking back of it, it may have been something else.

The steps I took were:

- booted from CF: EWF wasn't working
- remembered that the CF was still marked removable, made it fixed.
- booted: EWF wasn't working
- shut down, disconnected the CD and Floppy
- booted: EWF was working.

Maybe it's marking the CF fixed that did it, but only after an extra
reboot. Is that possible?

I actually booted several times before it worked, but I'm not certain if
there was more than one boot between marking the CF fixed and removing the

Slobodan Brcin \(eMVP\)

- booted from CF: EWF wasn't working

Expected. First CF PnP enum would enter registry entries under
Since this is first time that volume was detected EWF would not be attached
to this volume.
- remembered that the CF was still marked removable, made it fixed.
- booted: EWF wasn't working

Expected. Again new first CF PnP enum would enter registry entries under
So again same story with EWF. One more restart would be needed.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question