Can't seem to update Windows 2000 pro - no wuapi.dll file?



fter several months of having no problems updating Windows 2000 pro,my
browser consistently stops at this point (it doesn't hang but just

"Windows Update is looking for available updates... 0% complete"

I followed some suggestions around the net regarding active x controls,
closing my AV and firewalls, starting various services, changing security
permissions, playing around with the HTTPS controls in the internet
options, but all to no avail. I was going to run several commands that
PC world site suggested but the following problem occurred when I tried:

Type "regsvr32 wuapi.dll" and then click OK

I got the following message telling me that the wuapi.dll can't be found:

I did a search for that dll file and it's nowhere on my hard drive.

Until that can be solved inputting the following commands would be

Regsvr32 _jscript.dll
Regsvr32 atl.dll
Regsvr32 msxml3.dll
Regsvr32 softpub.dll
Regsvr32 Mssip32.dll
Regsvr32 Initpki.dll

Any suggestions? I recently installed a Netgear router and the one major
change I made to my internet options was unchecking the box that
"automatically detects settings". (I've tried re-checking it and that
didn't work either).


Solved the problem thanks to a post by one Mr.
(e-mail address removed) (Sree Karunakaran[MSFT]) ( http://groups-

It was just a simple run of these commands:

Please re-register the following files:
regsvr32 msscript.ocx
regsvr32 dispex.dll
regsvr32 vbscript.dll
regsvr32 scrrun.dll

1. Click "Start," and then click "Run."
2. Type regsvr32 msscript.ocx in the "Open" box and click "OK."
3. Repeat for dispex.dll,vbscript.dll, and scrrun.dll.

If only I found that post 2 hours ago!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question