Can't connect to tunnelled remote desktop


R

Robert S

This might not be a "pure" windows question, but here goes . . .

I'm trying to set up a tunneled connection to a remote XP Pro computer using
openssh. The method is outlined here:
http://www.blisstonia.com/eolson/notes/smboverssh.php (using port 3389
instead of 139). Essentially I've created a MS Loopback Adaptor with the
addres 10.0.0.1 and I've tunnelled port 3389 to this (using the freeware
program PuTTY). I then open Remote Desktop with the address 10.0.0.1. It
works on several of my PCs with no problem, but one machine refuses to
connect and gives the message "The client could not connect. You are
already connected to the console of this computer. A new console session
cannot be established".

I'm not aware that I'm already connected to the console of this computer -
can anybody explain? Is there some service that needs to be disabled?

I've tried disabling my firewall (ESET) and disabling fast user switching,
but these measures don't help.
 
Ad

Advertisements

A

Anteaus

It sounds like terminal services ae running on the local compuer, and are
bound to the loopback adaptor. In which case you either need to temporarily
stop the local TS, or else alter the bindings.

You are already (directly) connected as a logged-on user of the local
computer, hence the message.

You might also need this patch, though I think it only applies to loopback
addresses in the 127.x.x.x range:
http://support.microsoft.com/?id=884020
 
R

Robert S

Hi.

I can't disable terminal services - presumably because other services depend
on it (I think Fast Use Switching and Infrared Monitor do).

I was unable to install the patch because I've got Service Pack 3 installed
and it won't install.

Where to from here? How would I "alter the bindings"?
 
Ad

Advertisements

R

Robert S

I've solved this problem by redirecting port 3389 to 3390 with my ssh client
then connecting to 10.0.0.1:3390

Its interesting that using ssh with data compression makes a huge difference
to the connection speed.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top