Can't Boot XP With Iomega Zip Drive Connected


Jim H

I am running XP Home Edition and recently installed an
Iomega 250mb Zip Drive. I downloaded the latest software
from their website.

The computer will not boot up with the Zip Drive connected.
It boots fine if it's disconnected. I tested the drive on
another computer running Windows 2000 and the drive
works... I have researched this and the Iomega site suport
said the only thing that needed to be done was update the
iomegaware software. Well that doesn't work...

<b> Anyone have a work around for this? </b>



You hit the nail on the head, Jim.

I recently was in the process of installing Windows XP on a friends
computer, which had an Iomega ZIP-100 drive. The install went through
without a hitch, but afterwards I saw that the hard drive (the system) drive
was Drive E, not Drive C. The Zip drive was drive C, and a CD-ROM drive was
Drive D.

Windows XP ran just fine though. The only trouble was, some of the 3rd party
install programs expected the system drive to be Drive C. Thus I was not
able to install some of the 3rd party software my friend needed.

I never got around to using the ZIP drive after I realized what was going
on. So the boot problem you mentioned did not rear its ugly head. I just
opened up the case, disconnected the Zip drive, removed the hard drive
partition and reformatted as FAT32 with a W98 Start Up floppy, reinstalled
XP and used NTFS, and the system drive became Drive C. Then I shut down,
connected the Zip drive, powered the computer back up, and it was
recognized as a B drive (not a floppy drive, though. The BIOS had the B
floppy drive disabled). After that all of the 3rd party install software

By the way, Microsoft knows about the Zip drive problem for Windows XP, and
they have published a knowledge base article about it. Wish I had known
about that in advance. Would have saved me a lot of time.


No, that's not the problem. XP was already installed and
running. I installed the software for the zip drive first
and shut down the computer then I attached the Zip drive
to the system.


Bob Harris

A wild guess, but could you be exceeding the capacity of your power supply?
I once had a Gateway that would not boot if I left an external USB hub
attached. The hub worked fine elsewhere, and other USB devices worked OK on
the Gateway. However, this was the last in a string of " improvements" I
had made, each of which used a bit more power than the last.

Now for a bit of clarifiaction: When I say that my Gateway would not boot,
I mean that it would not ven do all the BIOS checks, also called POST. You
know, that black screen with white characters that flies by early in the
boot process. In fact, it did not even get far enough to check the floppy
drive, from whihc I could have booted to DOS. And, it certainly nver made
it anywhere near recognizing that I had a hard drive to show an XP log-in

If you get up to some level of XP, such as the screen that offers F8 for a
safe boot, then you are well past the BIOS checks. In fact, if offerred F8,
try it. If safe mode works, then some drive or drivers are likely
conflicting. Although it is hard to imagine bad ZIP-drivers resulting
anything but a non-workign ZIP drive.

Of course, do not boot with a disk in the ZIP drive. Some motherboards can
boot from a ZIP, and a non-system ZIP might stall things. Although, the
more likely response of the PC would be to try booting form some other
device, like the hard drive.

Whihc, brings up an interesting thought. The PC BIOS has, of ourse, been
set to boot from a class of hard drives. If the only hard drive is an
internal disk, this is unambiguous. However, with a ZIP attached, if is
theoretically possible that the BIOS is looking to boot from the ZIP, in
preference to the internal hard drive. A quick test of this theory would be
to insert a bootable floppy and see whether the PC uses that, since a floppy
is almost always on the list of boot devices. Repeat the test with a
bootable CD. If the floppy and/or CD boot the PC, with the ZIP connected,
then the power supply is NOT the problem, and the BIOS settings likely are.
If none of the above boots the PC, think about that power supply again. As
a test, try disconnecting te CD reader/burner and all external USB and
firewire devices and booting, but with the ZIP attached.

As for drivers, XP has built-in drivers for common IOMEGA products, so
installing the latest IOMEGAware is not necessary. my new home-made PC has
an internal ZIP-250, and I literally plugged it in, powered on, and in about
10 seconds it was ready to go. XP booted, found the hardware, loaded
drivers, etc.

Brian Coats

This may some strange. Unplug your zip drive. Then uninstall the
iomega software totally. Reboot. Plug-in the zip drive with window
xp operational. If it does not recognize the zip drive. Then reboot.
It should. Then use it that way. With xp iomega driver you will
have limited copy capacity. (Xp or Iomega with think the drive is
full-when it not). You can still access you data on a full disk.

I uninstalled the iomega soft because of the copy machine problem with
a floppy. The software would not let you copy a floppy. I tried
their fix suggested it didn’t work. I tried iomega support. They
won’t answer your questions or give you fixes that won‘t work. Then
you call them they want to charge you for the answer because they
don’t support the zip drives as it no longer supported. What even
funnier it should have been. I just recently bought at a store and
supposed to be under warranty.

Brian Coats

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question