Advice on removing dual Boot


T

Tom C

I am running Windows XP Pro on a different computer not connected to me
network at this time. The computer did have an additional hard disk which
had Windows 7 installed. That drive is no longer in the computer, but when
I boot the computer, I get the option to boot into Windows Seven or an
earlier version of Windows. Choosing the earlier version will boot to XP
Pro. I looked for the boot.ini file but only found the backup which looks
good. I do not know what file Windows Seven laid down to act as the boot
file. Can you tell me what I need to do to get rid if the dual boot options
so when I do boot it goes directly to XP?
 
Ad

Advertisements

D

db

you can edit the boot.ini and
remove the line entry for that
unwanted o.s.

--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~
 
A

AJR

The follofwing will provide access to boot.ini and should remove Win 7
entry:
Star>run>msconfig>boot.ini tab> select "check all boot paths".
 
P

Peter Foldes

Not so simple as removing the line from boot.ini. Windows 7 left a hidden partition
on the other drive which has to be removed. This is what you call new technology
 
Ad

Advertisements

D

db

I have w7 in vpc and didn't see
anything unusual.

perhaps, my suggestions for
people to use vpc or virtual
box for installing and playing
with other o.s.'s

should be taken seriously,
now that you've pointed out
a nuiscance.

--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~
 
A

Al and Darlene

Note from original post "... did have an additional hard disk which had
Windows 7 installed. That drive is no longer in the computer...." -Win 7
installation (dual boot) modifies the boot.ini to redirect to Win7 boot
manger located on Win 7 disk (if a partition is used instead of separate HD
use of BCDEdit or a third party boot manager would be recommended) -
removing boot.ini entry should do it.
 
T

Tom C

Thanks everybody.

There is one small problem though. There doesn't seem to be a boot.ini
file. I searched for the file and even searched hidden and system files.
Windows could not find the boot.ini file.

Since the drive that contained Windows Seven no longer exists, it obviously
won't be there either.

Hmmm. Any ideas here?
 
J

John John - MVP

Enter the following in the Start menu Run box:
%systemdrive%\boot.ini If the file exists Notepad should open it.

But..., Windows 7 doesn't use the boot.ini file to boot, there will be
no references to it in that file, you're barking up the wrong tree!

To remove the Windows 7 boot loader you must dislodge it from the boot
sector of the active partition and then return the boot sector to Ntldr.

Run this command with the Bootsect.exe utility from the Windows 7 DVD:

x:\Boot\Bootsect.exe –NT52 All

x being the drive letter of the Windows 7 DVD.

This is explained here: http://support.microsoft.com/kb/919529

Running the FIXBOOT command from the Windows XP Recovery Console will
also return control of the boot process to ntldr.

Or, use the EasyBCD utility suggested by JS in the first reply to your post.

After you restore ntldr to the boot sector make sure that you have a
valid boot.ini file at C:\.

By the way, do you by any chance have the Ask toolbar installed? There
have been several reports of missing boot.ini files in these groups and
the Ask toolbar has been identified as a culprit in the disappearance of
the file.

John
 
Ad

Advertisements

R

Richard

re: Missing Boot.ini

Either Control Panel> System
or hold Windows logo key and press Pause/Break
for System Properties,
click Advanced (tab)
under Startup and Recovery, click Settings
under System startup, the top item is Default operating system

Click Edit button and Boot.ini should open in NotePad
Here's what mine says for a single operating system:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /noexecute=optin /fastdetect

Note: That last line was split after "XP", recombine it.
(turn off Format>Word Wrap in Notepad)
Make sure there are spaces before the /slash marks,
but no spaces before the \backslash marks.
See reply by "John John - MVP" also.

HTH. (Hope This Helps. :)
--Richard
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top