Add Text - Mode Nic Driver to RIPREP image


G

Guest

Hi, I have a Win 2003 RIS Server.

I have successfull enabeled OEM-Driver in the CD-BASED / FLAT Image.

Now I want to add the Networkdriver for the TextMode Part of the Setup /
Installation process?
This is a RIPREP-Based Image!

Just adding it to i368 does not work!

Where do I have to store the driver?

Please help!
 
Ad

Advertisements

G

Guest

Thank you NIC Student,

you described how to integrat a CD-Based "FLAT" Image.

I am looking for a way to integrate NIC-Driver into a RIPREP- BASED Image.

In detail for the first Part of the Setup - the "blue"- Textbased Part.

The Image already exists- where do I have to copy the Driver-Files?

(The GUI Part works already)
 
N

NIC Student

My site tells you how to do what you ask - it is very granular. To get your
riprep'd image to work is simple once you get your cd-based images to work,
but the riprep image also must be altered. To see what to do from there,
read the section on the Intel Pro/100 driver, it is a how-to for riprep'd
images although the driver files may vary if they are not Intel.

http://www.mvps.org/serverstuff/
 
G

Guest

I now edited the .SIF of the RIPREP-Image
OemPreinstall = yes
and so on.

then I restarted the BINL Service

and - the blue/Text Setup Part hangs with no Network-Card
---------

because of my Timeline I used a "Workaround"

Workaround:
I take a second NIC acepted by RIS.
After copying of Image and the reboot I take it away and used the integrated
Nic
for the GUI-Setup-Part.
Deleted the RIS-ID
 
Ad

Advertisements

G

Guest

Onboard HP-Compaq dx6100
Broadcom b57xx Version 7.86.0.0

For the Textmode of the CD-Based Image I edited the b57win32.inf
Then copied this with b57win32.cat and b57xp32.sys into the i386 directory.

In de GUI-Part of CD-Based Image I used the Oringinal b57win32.inf
and copied it b57win32.cat, b57win32.inf and b57xp32.sys to
\$oem$\$1\Drivers\Nic

Restartet Binl

and the CD/Flat Image worked.


RIPREP-Image:

Just editing the i386\templates\riprep.sif the Unattendet-Section and
restart the BInl?

It sounds to me like this is for the GUI-Setup.

Did I not have to copie the Drivers to the RIPREP-Path?

merci
 
N

NIC Student

Both nics fail? Did you overwrite any files when you copied to the i386
directory? Have you deleted the *.PNF files in the i386 folder and
restarted BINL?

When you edited the Broadcom b57*.ini file, what changes did you make? Here
is an example Broadcom alteration for their 440 driver:

RIS Notes for Dell Latitude 100L Broadcom 440x:

1. Download R71272.exe from support.dell.com, extract the files somewhere,
you need the bcm4sbxp.cat, bcm4sbxp.inf and bcm4sbxp.sys files from teh
WinXP folder.
2. Log on to the RIS server and stop the BINL service.
3. Open the i386 folder on the cd-based image that you are trying to use,
backup the bcm4sbxp.cat, bcm4sbxp.inf and bcm4sbxp.sys files by renaming
them if they exist.
4. Delete the bcm4sbxp.pnf file from the i386 directory.
5. Copy from the "WinXP" extracted files directory the bcm4sbxp.cat,
bcm4sbxp.inf and bcm4sbxp.sys files to the i386 directory of the cd-based
image on the RIS server.
6. Make a new folder inside the $OEM$\$1\Drivers\ folder called "Broadcom".
7. Copy from the "WinXP" extracted files directory all files to the \[Dir
name]$OEM$\$1\Drivers\Broadcom directory of the cd-based image on the RIS
server.
8. Edit the SIF to add the "Drivers\Nic\Broadcom" line (separate with a ";"
between lines, no spaces and enclosed the entire string in quotes).
9. Edit the bcm4sbxp.inf file:

In the .inf file that is to be placed in the
RemoteInstall\Setup\Language\Images\Dir_Name\i386 folder, remove NTx86.5.1
in two lines (see the following example).

Original:

[Manufacturer]
%V_BCM% = BROADCOM, NTx86.5.1

[ControlFlags]
ExcludeFromSelect = *

[BROADCOM.NTx86.5.1]

Revised:

[Manufacturer]
%V_BCM% = BROADCOM

[ControlFlags]
ExcludeFromSelect = *

[BROADCOM]

Only use the .inf file provided by the vendor for this purpose

10. Start the BINL service on the RIS Server.

Let's talk about your riprep.sif file. Here in an example of one of ours
(only relevent parts included):

[Unattended]
OemPreinstall = yes
Oempnpdriverspath = "\Drivers\nic\"
DriverSigningPolicy = ignore
FileSystem = LeaveAlone
ExtendOEMPartition = 0
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1

You don't need the driver files to the RIPREP-Path. I hope that helps you.

--
Scott Baldridge
Windows Server MVP, MCSE


"speedy"
 
G

Guest

Hi Nic Student,

Indirekt you answered me, that i have not to copy any Driver-Fils to the
RIPREP-Image.
On my RIS-Server I have two Flat-Images.
1. Windows Xp SP1 (that i yoused to make RISSETUP)
2. Windows Xp SP2 (newer)

Both Flat-Images were build wirh a with a SELECT-CD.
I think the second one has just become a Slip-Streame Update


Both Flat Images show as a Imagepropertie Version 5.1(0)


Solution:

I added the Drivers to the WinXp Sp1 Image too
and the Textmode-Driver works!

Thank you very much Nic Student
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top