ActiveX not allowed - No security bar popup


L

Lars-Erik Østerud

I have all security levels set to default. Still I cannot access sites
that need to install an ActiveX. Like OfficeUpdate or the
SpywareScanner at ZoneLabs. Only get an error that the ActiveX cannot
be installed and that I should click the yellow bar in IE to allow it,
but the yellow ActiveX warning bar never appears anymore on my system!

Have tried adding the sites to the trusted zone, didn't help eihter.

How do I repair this functionality in IE, making the bar appear again?
 
Ad

Advertisements

L

Lars-Erik Østerud

Don Varnau said:
Hi,
Try reversing the procedure in this section "To prevent the Information Bar
from being displayed for all websites" of this article
http://www.winxptutor.com/sp2/infobardl.htm

That's the strange part. I have it set to "Disable" automatic prompt.

THat should display the "info bar". But that does not happend.
Instead all ActivX'es are NOT downloaded (so I can't get anything
needing that to work, not even OfficeUpdate from Microsoft work :)

I could set it to "Enable" but then ALL ActiveXes will be downloaded
 
J

Jan Il

Hi Lars-Erik :)

Do you have 3rd party toolbars such as Google, Yahoo, or Yahoo Companion? If
So, disable them and see if that helps.

also...

How to troubleshoot failures updating your Office installation from the
Office Update Web site
http://support.microsoft.com/?scid=kb;EN-US;Q304498

and...

If you have McAfee, disable the McAfee ActiveX controls Applet filters in
the Internet Filter
window when you select Customize your VShield settings

"Your current security settings prohibit running Active X controls on this
page. As a result pages may not display correctly."
http://www3.telus.net/dandemar/acxen.htm
or
http://support.microsoft.com/default.aspx?scid=kb;EN;Q319585&LN=EN

Zone Err Msg: Your Current Security Settings Prohibit Running ActiveX
Controls on This Page...
http://support.microsoft.com/kb/q223310/

Hope this helps.

Jan :)
MS MVP - IE/OE
Smiles are meant to be shared,
that's why they're so contagious.

Replies are posted only to the newsgroup for the benefit or other readers.
How to make a good newsgroup post:
http://www.dts-l.org/goodpost.htm
 
L

Lars-Erik Østerud

Jan Il skrev:
Do you have 3rd party toolbars such as Google, Yahoo, or Yahoo Companion? If
So, disable them and see if that helps.

Nope, of course not :) All security settings and zone are reset to
standard too. Any "settings" that would affect the "info bar"?
 
J

Jan Il

Hi Lars-Erik :)

Here is some setting information on the Information Bar:

How to Use the Internet Explorer Information Bar
http://www.microsoft.com/windowsxp/using/web/sp2_infobar.mspx
Description of the Internet Explorer Information Bar in Windows XP SP2
http://support.microsoft.com/?kbid=843017
Turn off Information Bar messages Windows XP (Service Pack 2)
http://www.easysurf.cc/shortct.htm#ibar

also...see the infomation here:

In Internet Explorer, on the Tools menu, click Internet Options. On the
Advanced tab, scroll down to the Security section of the list. Select the
Allow active content to run in files on My Computer check box, and then
click OK.

More information on that option (must read) - Local Machine Zone Lockdown:
http://msdn.microsoft.com/security/productinfo/XPSP2/securebrowsing/locallockdown.aspx

Local Machine Zone Lockdown - Developer Implications:
http://msdn.microsoft.com/security/productinfo/XPSP2/securebrowsing/lockdown_devimp.aspx

Mark of the Web:
http://msdn.microsoft.com/library/default.asp?url=/workshop/author/dhtml/overview/motw.asp

Allow active content to run in files on My Computer - Windows XP Service
Pack 2:
http://www.winxptutor.com/lmzunlock.htm

Hope this helps.

Jan :)
MS MVP - IE/OE
Smiles are meant to be shared,
that's why they're so contagious.

Replies are posted only to the newsgroup for the benefit or other readers.
How to make a good newsgroup post:
http://www.dts-l.org/goodpost.htm
 
Ad

Advertisements

L

Lars-Erik Østerud

Jan Il skrev:
In Internet Explorer, on the Tools menu, click Internet Options. On the
Advanced tab, scroll down to the Security section of the list. Select the
Allow active content to run in files on My Computer check box, and then

This one was not checked, is this what is preventing all ActiveX'es?
But why's still Windows Update working then (but none other)?

BTW: Do "Enable install on demand" and "Enable third-party browser
extensions" have to be enabled to download any ActiveX controls?
 
L

Lars-Erik Østerud

Lars-Erik Østerud skrev:

I double checked with a work-computer, all setting are equal.
But still "Office Update" does not display the info bar.

Only a message about an ActiveX needed to be installed
and that I should click on the info bar (which is not there)

Have tried adding that site to the Trusted ones too...

BTW: The info bar does appear if I open a web-pages on local disk
and that tries to start a Java applet. Then it asks :)
 
D

Don Varnau

Lars-Erik Østerud said:
BTW: Do "Enable install on demand" and "Enable third-party browser
extensions" have to be enabled to download any ActiveX controls?

I don't think those have to be enabled. If Windows Update works, but Office
Update doesn't, have you entered microsoft into Trusted Sites as
"*.microsoft.com" without the quotes ? And you should uncheck "Require
server verification (HTTPS) for all sites in this zone."

Less likely to help, but go to [C:\WINDOWS\Downloaded Program Files] switch
to Details view and remove any objects which are damaged.

Have you cleared the IE cache recently? It's a good first step for any type
of download problem.

Are you sure that a third-party security program isn't causing this? Norton
Internet Security?

Something in this article may help:
870700 - How to troubleshoot problems accessing secure Web pages with IE 6
[XP] SP2: http://support.microsoft.com/default.aspx?scid=kb;en-us;870700

Don
[MS MVP- IE/OE]
 
Ad

Advertisements

G

Guest

Jan Il said:
also...see the infomation here:

In Internet Explorer, on the Tools menu, click Internet Options. On the
Advanced tab, scroll down to the Security section of the list. Select the
Allow active content to run in files on My Computer check box, and then
click OK.

Thanks a WHOLE lot for your information. I was going crazy because the
information bar simply would not stop after 'disabling' it for activex and
downloads. Somehow, the "Allow active content to run in files on My Computer"
box had unchecked itself, I know I didn't do it, lol. Yours is the first post
or answer I found anywhere in several days of searching that actually solved
my problem, MANY thanks.
- P.S. I think Microsoft should include this information in the 'Information
Bar Help' under the 'To stop blocking files and software downloads with the
Information Bar' heading, sure would've helped.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top