ActiveX controlls blocked on IE


G

Guest

Windows XP Home SP2
AVG antivirus, Windows firewall.

When browsing pages with ActiveX controlls the IE information bar reads:
"Your security settings do not allow Web sites to use ActiveX controls
installed on your computer. This page may not display correctly. Click here
for options."

Clicking on the bar, the ONLY option available is Help. The option to
install or allow ActiveX controlls is not there.

I have tried everything I could find here and on the net to fix this problem
and nothing works. Reinstalling XP is NOT an option. The PC is 100% free of
malware and completely up to date (WindowsUpdate works just fine as you may
notice).

Creating a new user account does not fix the problem, the blockage is
machine-wide.

Help is needed ASAP!

Thank you for your reply.
 
Ad

Advertisements

J

Jon Kennedy

On the Tools menu, click Internet Options, click the Security tab, click the
Internet Web content zone, and then click Custom Level. In the Settings
box, click Enable or Prompt under Download signed ActiveX controls, Download
unsigned ActiveX controls, Initialize and script ActiveX controls not marked
as safe, Run ActiveX controls and plugins, and Script ActiveX controls
marked safe for scripting. Click OK, and then click OK again.

Don't know about AVG, but some anti-virus software have ActiveX blocking
options.

If no joy, make sure the proper values for the above are being written to
your registry:

Description of Internet Explorer security zones registry entries
http://support.microsoft.com/kb/182569/EN-US/

And try going to Start...Run and type in "regsvr32 comcat.dll" (no quotes),
click Okay.
If no joy, do the same to these:
Actxprxy.dll
Advpack.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll

If still no joy, also see...

A Web page that contains a custom ActiveX control may not load as expected
in Internet Explorer due to defense in depth changes introduced in
cumulative security update 896688 (MS05-052)
http://support.microsoft.com/kb/909738/en-us
 
G

Guest

If I set the ActiveX security settings manualy it works. But the information
bar keeps saying that the computer settings pose at risk and to click the bar
to fix it.

This confirms my theory that the problem has to be with the registry.

I need it to work with the default settings as it should.

Thanks Jon
--
"There are no shortcuts to a job well done"


Jon Kennedy said:
On the Tools menu, click Internet Options, click the Security tab, click the
Internet Web content zone, and then click Custom Level. In the Settings
box, click Enable or Prompt under Download signed ActiveX controls, Download
unsigned ActiveX controls, Initialize and script ActiveX controls not marked
as safe, Run ActiveX controls and plugins, and Script ActiveX controls
marked safe for scripting. Click OK, and then click OK again.

Don't know about AVG, but some anti-virus software have ActiveX blocking
options.

If no joy, make sure the proper values for the above are being written to
your registry:

Description of Internet Explorer security zones registry entries
http://support.microsoft.com/kb/182569/EN-US/

And try going to Start...Run and type in "regsvr32 comcat.dll" (no quotes),
click Okay.
If no joy, do the same to these:
Actxprxy.dll
Advpack.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll

If still no joy, also see...

A Web page that contains a custom ActiveX control may not load as expected
in Internet Explorer due to defense in depth changes introduced in
cumulative security update 896688 (MS05-052)
http://support.microsoft.com/kb/909738/en-us
 
G

Guest

Hi Jon,

We might be into something here.

I had already registered some dll's, but not most of the ones you mention.

Here's is the result of attemping to register these dll files:

advpack.dll -> FILE NOT FOUND

inseng.dll -> FILE NOT FOUND

url.dll and wininet.dll -> ERROR: "xxx.dll was loaded, but the
DllRegisterServer entry point was not found. The file cannot be registered."

All the other .dll files registered succesfuly.

I wonder if this can be fixed at all.

Thanks for your help.

--
"There are no shortcuts to a job well done"


Jon Kennedy said:
On the Tools menu, click Internet Options, click the Security tab, click the
Internet Web content zone, and then click Custom Level. In the Settings
box, click Enable or Prompt under Download signed ActiveX controls, Download
unsigned ActiveX controls, Initialize and script ActiveX controls not marked
as safe, Run ActiveX controls and plugins, and Script ActiveX controls
marked safe for scripting. Click OK, and then click OK again.

Don't know about AVG, but some anti-virus software have ActiveX blocking
options.

If no joy, make sure the proper values for the above are being written to
your registry:

Description of Internet Explorer security zones registry entries
http://support.microsoft.com/kb/182569/EN-US/

And try going to Start...Run and type in "regsvr32 comcat.dll" (no quotes),
click Okay.
If no joy, do the same to these:
Actxprxy.dll
Advpack.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll

If still no joy, also see...

A Web page that contains a custom ActiveX control may not load as expected
in Internet Explorer due to defense in depth changes introduced in
cumulative security update 896688 (MS05-052)
http://support.microsoft.com/kb/909738/en-us
 
G

Guest

Hi, CASE CLOSED, here's the update.

I had already done 7 of the applicable steps mentioned here:
http://support.microsoft.com/default.aspx?scid=kb;en-us;822798

I exported and imported several keys and subkeys of the registry from an XP
working correctly to the computer with the mentioned problem. No luck there
either.

I uninstalled and disable all toolbars, firewalls, BHO's, ActiveX, etc.

I re-registered or attempted to register about 12 differents dll files
including the ones you mentioned. No luck there either. I found out that you
cannot register mshtml.dll if you have IE 7 installed, it can only be done if
you have IE 6 SP1 and probably
previuos versions. (This is good info).

I've pretty much done everything that could be done to my knowledge.

So before doing an in-place reinstallation of XP, I wanted to attempt to
register de mshtml.dll by uninstalling IE7.

UNINSTALLING IE7 FIXED THE PROBLEM RIGHT AWAY. I rolled back to IE6, made
sure everything its as it should, registered a few dll's just in case and
reinstalled IE7.
Now everything works fine.

I still have to see if the problem re-ocurrs after IE7 current updates are
installed, maybe the problem came from there.

Thank you all for your help!

--
"There are no shortcuts to a job well done"


Jon Kennedy said:
On the Tools menu, click Internet Options, click the Security tab, click the
Internet Web content zone, and then click Custom Level. In the Settings
box, click Enable or Prompt under Download signed ActiveX controls, Download
unsigned ActiveX controls, Initialize and script ActiveX controls not marked
as safe, Run ActiveX controls and plugins, and Script ActiveX controls
marked safe for scripting. Click OK, and then click OK again.

Don't know about AVG, but some anti-virus software have ActiveX blocking
options.

If no joy, make sure the proper values for the above are being written to
your registry:

Description of Internet Explorer security zones registry entries
http://support.microsoft.com/kb/182569/EN-US/

And try going to Start...Run and type in "regsvr32 comcat.dll" (no quotes),
click Okay.
If no joy, do the same to these:
Actxprxy.dll
Advpack.dll
Inseng.dll
Jobexec.dll
Url.dll
Urlmon.dll
Wininet.dll
Wintrust.dll

If still no joy, also see...

A Web page that contains a custom ActiveX control may not load as expected
in Internet Explorer due to defense in depth changes introduced in
cumulative security update 896688 (MS05-052)
http://support.microsoft.com/kb/909738/en-us
 
Ad

Advertisements

J

Jon Kennedy

Thanks for the update and all the info you've provided. Good work on your
part! Hopefully this will be helpful to others in the future - much
appreciated.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top