ACPI Problem when trying to install (yes i did search!)



When I try to install Vista on my Clevo M120W, right after 'copying' files
(after the very first progress bar that appears) I get a blue screen saying:

"The BIOS is not fully ACPI compliant. Please contact system vendor for
upgraded BIOS"

Ok I understand this but when I check my notebook's manual it says my laptop
DOES support ACPI 1.0b and 2.0!! It also works fine in XP (sleep, hybernate,
....). I tryed some of the suggestions here (like pulling out all devices like
mouse and stuff) but it didn't change anything. In my BIOS settings there's
nothing related to ACPI.

I'm now wondering how I can get this 'BIOS upgrade'? On the Clevo website
there are NO updates. I once updated my BIOS, but I received that one via
mail. I mailed them again but they don't respond now. I also tried going on
various 'bios update' websites but either they are paying ( -
should I trust them?) or there's nothing usefull.


There was an MS KB article I read recently that covered ACPI. If the BIOS
has an embedded date in it that is prior to 2000, it will look at a file on
the DVD and lookup the motherboard (as I recall) and if it's not on the
list - you get the error message. There is also a work-around but I don't
remember enough of it to be accurate but you can essentially turn this
lookup feature off by modifying a file.

I ran into this when I was testing an old Abit BH6 motherboard to see if
Vista Basic would even load - it gave me the ACPI error. My BIOS firmware
date was 2000 but the actual date embedded in the code that shows the
copyright dates of the BIOS was 1999. I didn't go any further with that old
board but at least that experience may help you now. Do a search on MS site
in their Knowledge Base area for ACPI.

Bob S.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question