Access denied on USB memory stick




I have a strange problem. Suddenly I cannot access my USB memory stick.
When I plug it in it is recognized, and the drive letter is assigned to
it. But when I try to open or explore its drive I get an error "I:\ is
not accessible, access is denied".

I checked the USB stick on other computer and it works fine. I also
have another USB stick and it's the same with it. Other USB devices on
this computer (camera, modem) are working fine.
I tried to reinstall the Mass storage device driver, but it did not
help. I contacted the USB company for help but all they could find is
that the USB device itself is working properly. They gussed that maybe
there's some collision in the drive letters assignment, but I see
nothing like that.
I'm using WinXP SP2.

Anyone have any idea what could cause this, or where else can I look?
It's getting quite critical.



OK, I have some more info on this -
I tried bringing Windows up in safe mode - and then I can access the
USB drive.
I guess this means that there is some conflict or that something is
blocking the access to USB drives on my system.
I just have no idea how to locate what's causing the problem...

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question