2003 word spell check not working


N

Nicole

Hi,

My spell check settings under Tools> Options> Spelling and Grammar seem to
be okay. Publisher spell check is working. When I try to mispell and spell
check it says "completed checking document" or words marked "Do not check
spelling or grammar" skipped (cannot find this in settings).

Can anyone help me get my spell checking working again?

Cheers Nicole
 
Ad

Advertisements

M

macropod

Hi Nicole,

The "Do not check spelling or grammar" setting is found under Tools|Language|Set Language.
 
Ad

Advertisements

J

Julian Turner

Hi,

My spell check settings under Tools> Options> Spelling and Grammar seem to
be okay. Publisher spell check is working. When I try to mispell and spell
check it says "completed checking document" or words marked "Do not check
spelling or grammar" skipped (cannot find this in settings).

Can anyone help me get my spell checking working again?

Cheers Nicole

Hi

All ranges of text in the document have an API (macro-programming)
property called "NoProofing" which causes the word spell checker to
skip them.

This corresponds to the tick-box macroprod pointed out: "the "Do not
check spelling or grammar" under Tools|Language|Set Language."

The tick box will show the status of the NoProofing property for the
paragraph your cursor is in (or the text in your selected range) and
will either be:-

- unticked (proofing will happen)
- ticked (no proofing will happen)
- grey + ticked (some parts of the selected area have the property set
and some don't).

I have absolutely no idea how this property comes to be set (ticked)
as I have never actually selected it in my life, but sometimes
(particularly third party documents I receive) the property gets set
(seemingly at random), and is one of the wierd aspects of Word which
the help files do not satisfactorily explain.

Ideally you should be able to select the whole of your document, and
then untick the box, so that proofing is enabled for all text. But
this does not always work.

So I use a macro to do it for me:-

Private Sub SetProofing()

Dim MyParagraph As Paragraph

For Each MyParagraph In ActiveDocument.Paragraphs

MyParagraph.Range.NoProofing = False

Next MyParagraph

End Sub

Regards


Julian
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top