2-Win2K pcs, 1 Win98SE pc...help



I have a home peer-to-peer network (no router or hub) that
after going through some initial hassles has worked
incredibly well for the past two years with two Win98SE
machines and one Win2K machine. Sharing printers, files
and ICS has worked well. However, a few weeks ago, it was
time for some routine maintenance on one of the Win98SE
machines and I decided to reformat and install Win2K.
Since that time I have been unable to get this second
Win2K machine to be recognized on the network. The
remaining two machines (one Win98SE and one Win2K machine)
continue to work flawlessly. So you know, the Win98SE
machine serves as the ICS server, while the Win2K machine
is the print server.

From past experience the protocols I use are NetBeui for
the network and TCP/IP for the ICS. Client for Microsoft
Networks and File and Printer Sharing are both installed.
The second Win2K machine setup (I believe) is exactly the
same as the first. Occasionally, this pc will see the
Win98SE machine, but cannot access the shared files. The
two Win2K machines never see each other.

The ipconfig/all shows the non-connecting Win2k pc has a
different subnet mask of as compared to the
other two pcs with a subnet mask of While I
could manually get everything in sync to use ICS
everything has to be left to automatically assign the IP
address. The IP address is also considerably different
( versus and

Can someone give me some suggestions on getting this
working again? Is there something on the host Win98SE
machine that is screwing things up...Help!

Michael Holzemer

Your new load is using the auto settings for tcp/ip. Set the IP address to mask an set the gateway to the ICS machine.

Michael Holzemer

From W2K help:
If a DHCP server is not reached or leased configuration fails, the computer
uses APIPA to automatically configure TCP/IP. When APIPA is used, Windows
2000 determines an address in the Microsoft-reserved IP addressing range
from through This address is used until a DHCP
server is located. The subnet mask is set to

The ICS machine is a DHCP server. So you can try release and renew, reboot
etc. to see if it will pull an address.

You mentioned you do not have a hub. How are the computers connected


The pcs are daisy chained via the telephone lines. You
don't need a router or hub for a peer-to-peer network.

What you described is exactly what has happened. What
topic is this under in Win2k help?

Two more questions...how do I release and renew an IP
address, and what is APIPA?

I got a feeling the easiest thing to do is probably to
turn off ICS on the Win98SE machine and then reimplement.


I could not get the pc to release or renew its IP
settings. However, for whatever reason I decided to
shutdown the other Win2K pc, with the Win98SE ISC host
left on. Upon bootup of the previously problem Win2K pc,
the IP address and subnet and gateway were all propertly
assigned. I then booted up the original Win2k pc which
connected as always with the network.

The network is back up and running perfectly with all
three pcs. After establishing user accounts on the Win2k
pcs, printers and files are shared with no issue.

Is there any explanation for this?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question