2.0 USB port loads wrong driver -- runs as 1.1



I have a Sony Vaio V505AX notebook. It has built-in USB ports that use the
Intel 82801 chipset -- these support USB 2.0. I'm running XP Pro SP2, and
have all the latest drivers loaded.

My built-in USB ports run slow, at 1.1 speeds. The reason for this seems to
be that the Host Controller for the ports is loading usbuhci.sys, instead of
usbehci.sys -- only the latter supports 2.0.

I've tried re-installing the SP2 update, re-installing the USB ports, and
even trying to force the installation of usbehci.sys. None of this worked.

I have a PCM USB adapter card that uses the VIA chipset. The computer
correctly recognizes the card and installs usbehci.sys for VIA Host
Controller. Not surprisingly, this works fine at 2.0 speeds.

What do I have to do to get XP to utilize the correct drivers to run my USB
2.0 ports at 2.0 speeds?

Thanks for any suggestions.

Yves Leclerc

Check the BIOS to see what level of USB has been enabled on those ports. Some
motherboards allow you to select 1.1 (fast) or 2.0 (high) speeds.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question