xp remote desktop bluescreen or how to shoot your pc


S

Shenan Stanley

<snipped>
http://groups.google.com/group/microsoft.public.windowsxp.work_remotely/browse_frm/thread/8c4ca8fdb2e87ba5/


Regarding commonnality, this issue is a showstopper for anyone planning
to
do a desktop virtualization.

I'm currently running XP on VMware platform and this issue is driving me
crazy. I connect to this virtualized XP from various locations, and once I
forget to configure color depth of RDP connection, it's a death sentence
for
my desktop - next time I run a "correctly" configured RDP session, it
result
in BSoD.

So while I do agree Microsoft probably won't fix this as XP is now nearly
unsupported, I expect this issue to rise again if desktop virtualization
became mainstream while XP is still alive.

You mean unless you apply the patch given in the thread, right?

It's not like the fix wasn't posted in the very conversation you were
responding to. See below - the hotfix repaired the error completely.

Here is the relevant section of the conversation with a link to the fix...
May I suggest you to test a more recent build of Rdpdd.dll
(23-Jan-2009). In my eyes, this problem could be related to this
issue:

http://support.microsoft.com/kb/963038/en-us
I agree with the suggestion, although the issue does not give the error(s)
mentioned in the KB article.

Taking the screenshot out of the recorded examples I gave, you can see
the bluescreen states:

PAGE_FAULT_IN_NONPAGED_AREA
STOP: 0x00000050 (0xBC62FFF0, 0x00000000, 0xBF85B6B7,0x00000000)
win32k.sys - Address BF85B6B7 base at BF800000

The KB Article (http://support.microsoft.com/kb/963038/) refers to this
error:
STOP: 0x1000008E (Parameter1, Parameter2, Parameter3, Parameter4) in
RDPDD.dll
KERNEL_MODE_EXCEPTION_NOT_HANDLED_M

Screenshot of BlueScreen on Remote Machine:
http://picasaweb.google.com/lh/photo/YJ-Oxnn7HJOFcc-4_5AOkA?feat=directlink

But - what the heck? It's the best possibility yet and all the work is
done
except for this last part. So I tried it and recorded the results.

Resultant Video (showing the application of the fix, reboot and test
results...):

The fix seemed to work perfectly. Good find, Tom.

If you have Windows XP SP3 and your RDPDD.DLL file version is
5.1.2600.5749
or later - you should not have the issue that the OP is reporting.

The videos, pictures and KB article should get you everything you need -
since you can get the fix by reading the KB article, etc. Apply that
hotfix
to all affected machines.

If you just want the hotfix...
http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=963038

Do the obvious (in case it is not obvious, select the proper language, put
in a valid email address twice, type the characters you see. When you get
the email, follow the directions.)

Hopefully that will fix the problem for the OP and is well documented and
commented about enough to allow those who put effort into it and search
will
find the answer they seek. I would ask that the OP comes back and lets us
know if this resolves the issue for them - but it should - given the video
evidence. ;-) Would be nice closure, however.
** Although now I would also suggest getting the Remote Desktop Client 7.0
in addition. **

With the above - you should not be struggling anymore.
 
Ad

Advertisements

Joined
Aug 26, 2010
Messages
1
Reaction score
0
Great Stuff

Thank you, thank you, thank you. I could not figure out why I started crashing with RDP until I read this thread. Yes, my resolution was set to 15bit. Thanks again.
 
Ad

Advertisements

C

cjburian

It's a few years old now, but thank you to the contributors in this thread!I couldn't find a solution at support.microsoft.com because I was always searching for win32k.sys as part of my search string.

This problem is very easy to reproduce:
rdesktop from workstation into pc1.
remote desktop from rdesktop'd pc1 into pc2.
rdesktop from workstation into pc2.
etc etc

You don't have to go to the trouble to disconnect, you just have to steal the connection. I'll often have a bunch of rdp sessions open while I'm moving data or scripts around, and when I want to get into a machine, I don't look to see if I'm already in it from somewhere else, I just fire off a fresh session.

It's a hugely serious problem that was rebooting several production systemswith high visibility each time they went down. And it cropped up only when I started using a newer version of rdesktop which is apparently defaulting to different color depth than the old version. Of course I had no idea the issue was with color depth until reading this thread. In 4 years this problem hasn't reared its head until last month when my workstation was upgraded from CentOS to RHEL6.

Thanks again for the detailed explanation of the problem and for the location of the hot fix.

I have to chime in that the person who pooh-poohed the problem was unhelpful to the o.p. and others, even anti-helpful. Instructing somebody that their problem isn't really a problem is just plain wrongheaded.

Regards,
Chris
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top