XP, FTP and the Firewall


G

Guest

My company have clients that transmit data to us by FTP.

For the vast majority there is no problem, but in some cases the data is not
transmitted. We have tracked this down to the fact that these clients use
ADSL and a router.

We have tested the system using XP Remote Desktop and the FTP starts then
eventually times-out. Our server shows the file but with zero bytes received.

There are two other points. A small file can be FTPed without a problem. A
larger file of 5MB will not transmit. When we disable the XP Firewall the 5MB
will be transferred immediately.

As this does not happen with all clients with routers, we can only assume
that there is some setting within XP or the XP Firewall that is causing the
problem.

I have tried setting ‘Use Passive……’ off and opened Port 20 in the Firewall,
but it still will not transfer.

Have there been any XP updates to resolve this issue?

The FTP is run from within a Visual Basic program. The OS is XP Pro SP2.

Any suggestions would be appreciated.
 
Ad

Advertisements

Y

Yves Leclerc

My company have clients that transmit data to us by FTP.

For the vast majority there is no problem, but in some cases the data is not
transmitted. We have tracked this down to the fact that these clients use
ADSL and a router.

We have tested the system using XP Remote Desktop and the FTP starts then
eventually times-out. Our server shows the file but with zero bytes received.

There are two other points. A small file can be FTPed without a problem. A
larger file of 5MB will not transmit. When we disable the XP Firewall the 5MB
will be transferred immediately.

As this does not happen with all clients with routers, we can only assume
that there is some setting within XP or the XP Firewall that is causing the
problem.

I have tried setting âUse Passiveâ¦â¦â off and opened Port 20 in the Firewall,
but it still will not transfer.

Have there been any XP updates to resolve this issue?

The FTP is run from within a Visual Basic program. The OS is XP Pro SP2.

Any suggestions would be appreciated.
FTP also uses port 21 and the sending PCs should also using 'Passive FTP mode."
 
Ad

Advertisements

G

Guest

Sorry, I meant I had opened ports 20 and 21. I've tried it with "Use
Passive......" checked and unchecked but with no luck.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top