XP can't find 2nd monitor after upgrading from 98SE


D

Dudley Brooks

Just upgraded from 98SE to XP (system not powerful enough to run Vista).
In 98SE, had two monitors. Motherboard has built-in video, plus I
added 2 video cards to support the 2 monitors I have (once AGP, one
PCI). In 98SE, in Device Manager, had to disable (or uninstall, can't
remember which) the onboard video to get the 2 added cards to be
recognized and to get one of them to be the primary video.

In XP, one added card is recognized, and functions as primary video.
But onboard video and other added card both show "cannot start (code
10)". If I uninstall the onboard card, then every time I start up, the
Find New Hardware reinstalls it. If I merely disable it, the other card
still shows "can't start (error 10)". (I don't know if the other card
shows "can't start" when I uninstall the onboard card, since XP won't
leave it uninstalled to find out.)

Have tried everything Troubleshooter recommends: Uninstall and
reinstall (as mentioned above anyway), reseating the cards (and, anyway,
one of the "cards" is onboard, so it doesn't need to be reseated),
looking for new drivers. (XP finds the drivers, so it can't be that one
of the cards is no longer supported.)

Suggestions? Thanks.

-- Dudley
 
Ad

Advertisements

D

Dudley Brooks

Harry said:
Sounds like a broken video card.

It was working fine in the morning while I still had 98SE. The moment
XP finished installing later that day, it had stopped working -- and
nothing physical had happened to the computer (other than the CD drive
tray sliding in and out to insert the XP disk!)
Try using a different one.

Don't have one, can't afford one, don't think the old one is broken.

Other suggestions? Thanks.

-- Dudley
 
G

Guest

Dudley Brooks said:
Just upgraded from 98SE to XP (system not powerful enough to run Vista).
In 98SE, had two monitors. Motherboard has built-in video, plus I
added 2 video cards to support the 2 monitors I have (once AGP, one
PCI). In 98SE, in Device Manager, had to disable (or uninstall, can't
remember which) the onboard video to get the 2 added cards to be
recognized and to get one of them to be the primary video.

In XP, one added card is recognized, and functions as primary video.
But onboard video and other added card both show "cannot start (code
10)". If I uninstall the onboard card, then every time I start up, the
Find New Hardware reinstalls it. If I merely disable it, the other card
still shows "can't start (error 10)". (I don't know if the other card
shows "can't start" when I uninstall the onboard card, since XP won't
leave it uninstalled to find out.)

Have tried everything Troubleshooter recommends: Uninstall and
reinstall (as mentioned above anyway), reseating the cards (and, anyway,
one of the "cards" is onboard, so it doesn't need to be reseated),
looking for new drivers. (XP finds the drivers, so it can't be that one
of the cards is no longer supported.)

Suggestions? Thanks.

-- Dudley
Hi, you probably have a resource conflict of some sort.
The first thing i would do is disable the onboard video in the BIOS, or CMOS
SETUP, however you like to say it. this is accessed during POST, before
windows takes control of the machine. usually it is accessed by pressing the
DEL key at power on, but your computer may be different, consult your
motherboard manual or manufacturer website. This will prevent Windows from
seeing this hardware and trying to install any drivers for it. in the very
least it will be eliminated from the troubleshooting process.
The other thing i would keep in mind is that life goes smoother if both
cards you care about use the same driver. for example, say you have a VooDoo3
AGP card and a Rage PCI card, you could experience the problems you report.
Anyway, go ahead and turn off the onboard video in BIOS and go from there. I
hope this helped a little.
 
H

Harry Boyne

Can you try and go back to 98SE? Use your 98 CD as a boot disc. Let me know
if it works.

Harry
 
D

Dudley Brooks

Harry said:
Can you try and go back to 98SE? Use your 98 CD as a boot disc. Let me
know if it works.

Thanks for the suggestion. I'm going to try "engine code y"'s
suggestion first, since it's slightly simpler. If that doesn't work
I'll try your suggestions.

Just a couple of "paranoid" question, since I have had help suggestions
before which solved a problem but created even worse problems in the
process: Is it possible to boot from the 98SE disk without it trying to
install itself? And, since it's only on a CD, won't it find the XP
settings now, when it looks at the HD?

Thanks.

-- Dudley
 
Ad

Advertisements

D

Dudley Brooks

engine said:
The first thing i would do is disable the onboard video in the BIOS, or CMOS
SETUP, however you like to say it. this is accessed during POST, before
windows takes control of the machine. usually it is accessed by pressing the
DEL key at power on, but your computer may be different, consult your
motherboard manual or manufacturer website. This will prevent Windows from
seeing this hardware and trying to install any drivers for it. in the very
least it will be eliminated from the troubleshooting process.
The other thing i would keep in mind is that life goes smoother if both
cards you care about use the same driver. for example, say you have a VooDoo3
AGP card and a Rage PCI card, you could experience the problems you report.
Anyway, go ahead and turn off the onboard video in BIOS and go from there. I
hope this helped a little.

It sounded like it would help. But unfortunately the BIOS setup doesn't
include any provision to turn off the onboard video. It has the usual
basic nformation screen, a plug-and-play screen, a power setting screen,
and a boot drive screen. The only thing that even comes remotely close
to relating to the onboard video is on the plug-and-play screen:
PCI/PNP ISA UMB Region Exclusion and PCI/PNP ISA IRQ Resource Exclusion.

I don't know how I disabled it in 98SE. I vaguely seem to recall that I
used Uninstall in Device Manager and it stayed uninstalled. But I could
be misremembering.
 
D

Dudley Brooks

Please, any other suggestions? Thanks.

Dudley said:
It sounded like it would help. But unfortunately the BIOS setup doesn't
include any provision to turn off the onboard video. It has the usual
basic nformation screen, a plug-and-play screen, a power setting screen,
and a boot drive screen. The only thing that even comes remotely close
to relating to the onboard video is on the plug-and-play screen: PCI/PNP
ISA UMB Region Exclusion and PCI/PNP ISA IRQ Resource Exclusion.

I don't know how I disabled it in 98SE. I vaguely seem to recall that I
used Uninstall in Device Manager and it stayed uninstalled. But I could
be misremembering.
 
D

Dudley Brooks

For the problem below, I tried Harry Boyne's (second) suggested
solution: "Try using the 99SE CD as a boot disk". Result: All that the
disk does is give me the error message "Can't run under this version of
XP. Run in MS-DOS". But in MS-DOS all the disk does is try to
re-install itself.

I also tried "engine code y"'s solution: "Disable the onboard video in
the BIOS setup." But my BIOS setup doesn't include any screen that
enables/disables onboard video.

Any other suggestions? They will be gratefully accepted and tried. Thanks.
 
D

Dudley Brooks

I just discovered that the AGP card, an ATI 3D RAGE PRO AGP 2X (one of
the two which gets Code 10 -- the other is the onboard card) is listed
as using PCI bus 1, device 0, function 0. Is this bad (an AGP card
using a PCI bus)?
 
W

Wesley Vogel

If your intention is to use the plugin video card, disable the onboard video
in your BIOS. You should have done that when you added the plugin card.
Consult your BIOS manual.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
 
Ad

Advertisements

D

Dudley Brooks

Wesley said:
If your intention is to use the plugin video card, disable the onboard
video in your BIOS. You should have done that when you added the plugin
card. Consult your BIOS manual.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

As I mentioned in the post to which you are responding (see below),
another user already suggested that. But, as I also mentioned in that
post, I went into BIOS setup and did not find any screen which let me
disable the onboard video.

In
 
Ad

Advertisements

D

Dudley Brooks

Maybe your motherboard has a jumper setting to disable onboard video

I don't think it does -- but if it did, it would have already been set,
because I had already successfully disabled it for 98SE.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top