xp cannot access shared folders, vista can, xp can access printer



My Vista Business system is sharing its internet connection with 2
XP computers ( 1 Pro, the other home edition). I did not have a problem
until recently. The XP computers have no problem accessing the internet,
and I have installed and used a printer shared from the Vista system on the
XP home edition computer. I cannot access or even see the shared folders on
the Vista system. When either xp system expands My Network Places->Entire
Network->Microsoft Windows Network->workgroup all of the connected pcs are
displayed, clicking on the +next to the Vista's systemname makes the +
disappear, and clicking on the name gets the following error message " \\
Martins-new-pc is not accessible. You might not have permission to use this
network resource. Contact the administrator of this server to find out if
you have permissions. Access denied."

Vista Network & Sharing Center has network listed as private with
Network discovery, file sharing, public folder sharing and printer sharing
all on. Password protected sharing and Media sharing are off. I have read
all of the troubleshooting help files and am at a loss. All shares give
'Everyone' permission to access.The xp computers were able to access Vista
shares about two weeks ago andbefore that with no problem. In the interim I
have installed Visual Studio .Net 2008 plus recent automatic windows
updates. I feel that there is probably a simple solution since ICS and
printer sharing are working fine.

Any suggestions would be greatly appreciated!

Martins Gulbis

D Lirious

Presuming all computers are sharing the internet connection via a
wired/wireless router you are encountering classic Vista networking
Realize that Vista was programmed by morons who think you are an idiot:
there is no other way to explain the UAC and the way network sharing is
deliberately obfuscated.
Out of the box Vista expects you will place anything you want to share on
the network in its "public" folders and nowhere else. That the public folder
exists only on your C drive, which there are good reasons not to share,
never seemed to have occurred to the brilliant programmers in Redmond. If
you can live with that arrangement your life will be easier.
It has been my sad experience that it can take multiple tries and reboots to
get the sharing/ownership permissions to work properly. This can be very
frustrating if the computers are not physically near one another and you
have to go back and forth to see if following the instructions has actually
worked (as alas it often does not). The combination of XP and Vista on a
network is doubly frustrating as the rules for sharing network resources are
different (simpler on XP) and Vista has issues, never resolved, sharing with
wireless XP machines.
The problems are solvable but require more effort than it should.
At least you will soon be able to buy Vista SP3, I mean Windows 7, and start
over with new network rules.


Thanks for the information!! I have found the problem and am very impressed
by the Windows Network Problem Solver at http://winhlp.com/wxnet.htm .
I probably would have never figuredthis one out without it! I hope this
helps the many others I have read recently in nuber of forums, newsgroups

The following quoted from http://winhlp.com/wxnet.htm :

The RestrictAnonymous registry value
You have both the following symptoms:

a.. You can ping the computer by IP and by name.
b.. When you type on another computer, replacing computername with the
name of the inaccessible computer:
net view \\computername

you get one of the various "Error 5" error messages, like "System error 5
has occurred. Access is denied" or "Error 5: You do not currently have
access to this file. ..." (However, other commands, like

net use Z: \\computername\sharename

or typing the full network path into Windows Explorer may work.)

This can be caused by a registry setting named RestrictAnonymous. Go to the
computer which you cannot access, start a registry editor and change the
following registry value.

Value name: RestrictAnonymous
Value type: DWORD

If the value is 1 or even 2, change it to 0, reboot and retest. If the
problem is solved, leave the value at zero. If not, you can change it back
if you like.

On my system it was set to 1 which means annoymous users "cannot display
lists of domain user names, nor share names. Also, these users cannot view
security permissions, and they cannot use all of the features of Windows
Explorer, Local Users and Groups, and other programs that enumerate users or

I amnot sure whether something ha changed the value to a one recently, or
whether they way the value is interpreted by Vista has changed because of
either a Microsoft update or by my installing the Visual Studio 2008
Proffesional software package.

In either case it has solved the problem for me and I hope this info is of
some help to some of the many others experiencing similar problems.

A huge thanks for the info once again!


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question