Word 2007 add word to spell check grayed out


G

Guest

I want to add word to custom dictionaries, but the "Add to Dictionary" tab is
grayed out. I have already made sure that the option "Select from main
dictionary only" is not checked. I really need to add words to my custom
dictionaries (which I imported from an earlier version of Word). Can someone
help.
 
Ad

Advertisements

B

Beth Melton

Typically this is caused by a read only attribute that has been set on your
Custom Dictionary file or folder it is located in.

First click the Microsoft Office Button, click Word Options and then click
Proofing. Click the Custom Dictionaries button and verify you have a custom
dictionary. If so, then select it and note the file path at the bottom of
the list. Make note of the path (you can also copy the path as well), locate
the folder and the custom dictionary file and make sure both the folder and
file hasn't been set to Read Only.

If that isn't it, how did you import your old custom dictionary? What steps
did you use?
Please post all follow-up questions to the newsgroup. Requests for
assistance by email cannot be acknowledged.


~~~~~~~~~~~~~~~
Beth Melton
Microsoft Office MVP

Coauthor of Word 2007 Inside Out:
http://www.microsoft.com/MSPress/books/9801.aspx#AboutTheBook

Word FAQ: http://mvps.org/word
TechTrax eZine: http://mousetrax.com/techtrax/
MVP FAQ site: http://mvps.org/
 
G

Guest

Beth, I have two custom dictionaries showing in the UProff folder, and
neither of these is a read only file. I copied these from my desktop Word
'97 to use in my laptop Word 2007. They both show as DIC files. They may
both be full, and all I really want to do is add words to my spell check, but
as stated this is grayed out and I am unable to.
 
B

Beth Melton

Can you open the files you copied in the Notepad? If so, is each word on a
separate line? What are the file names? Have you tried creating a new custom
dictionary and setting it as your default?

Please post all follow-up questions to the newsgroup. Requests for
assistance by email cannot be acknowledged.

~~~~~~~~~~~~~~~
Beth Melton
Microsoft Office MVP

Coauthor of Word 2007 Inside Out:
http://www.microsoft.com/MSPress/books/9801.aspx#AboutTheBook

Word FAQ: http://mvps.org/word
TechTrax eZine: http://mousetrax.com/techtrax/
MVP FAQ site: http://mvps.org/
 
G

Guest

Thanks Beth. I changed the files to open from Word to Notepad. They do open
and each word is on a separate line. I then set up a new dictionary (a 3rd
custom) and had this open in Notepad. All 3 are marked as default
dictionaries. When I click on spell check, the "add to dictionary" tab is
still grayed out. I did find a long, long way around to get words added into
the new custom dic., but this is very time consuming. I still cannot
understand why this tab is grayed out when I have a open custom dictionary
that I know has sufficient space to add words. All three dictionaries are
set to use US(English). Could the language setting be causing some kind of
problem with this?

Thank you for your help to get this far.
 
B

Beth Melton

How are all three marked as "Default"? That could be why you are
encountering this issue - there should only be one default which is the one
Word adds your words to. I suspect Word doesn't know which dictionary to use
for your added words so it offers no option, except the disabled command.

What happens when you remove two of the custom dictionaries, make sure only
one is set as the default, and then add the others back?

Additionally, what if you open the files in the Notepad and copy/paste the
content to create one file out of the the three, and then list only one
custom dictionary?

Please post all follow-up questions to the newsgroup. Requests for
assistance by email cannot be acknowledged.

~~~~~~~~~~~~~~~
Beth Melton
Microsoft Office MVP

Coauthor of Word 2007 Inside Out:
http://www.microsoft.com/MSPress/books/9801.aspx#AboutTheBook

Word FAQ: http://mvps.org/word
TechTrax eZine: http://mousetrax.com/techtrax/
MVP FAQ site: http://mvps.org/
 
G

Guest

Beth, I'm sorry. Only the original custom dic is marked as default.
However, all three are checked in the custom dictionary dialog box. I
believe that the spell check is checking from all three dictionaries because
the new one I set up today only has a couple of words and these are being
spell checked now. As far as putting all three into one custom dictionary, I
believe that they are too large for that. At least they were for the Word 97
and that is why I had imported 2 custom dictionaries into Word 2007. I am
still, however, getting the grayed out "Add to Dictionary" box in spell check
and would like to know who to get that box active. Thank you for your help.
 
G

Guest

Also, Beth, the French modes box is set to traditional and new spelling. I
had tried changing before creating a new dictionary to see if it helped, but
it did not earlier. Would this make any difference to the problem I am
having?
 
S

Suzanne S. Barnhill

This is usually caused by a language mismatch. The language of Custom.dic
should be set to "All Languages." If another dictionary, for a specific
language, is set as the default, then the word you're trying to add must be
formatted with that language.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA

Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.
 
Ad

Advertisements

G

Guest

Suzanne, I have set all three custom dictionaries as "All Languages."
However, I still have the grayed out "Add to Dictionary" tab on the spell
check dialog box. On the French modes box under Word Options/Proofing, this
is set at traditional and new spelling. You only have three choices: New
spelling, traditional spelling, and traditional and new spelling. I really
do not know what this box means, and when I tried changing it earlier, it did
not make a difference as to my original question -- How do I get the "Add to
Dictionary" tab on the spell check dialog box to become active, so that I do
not have to take three or four time-consuming steps to add a word to the
custom dictionary? Can you help me with this? Thank you for your response.
 
G

Guest

Linda said:
Suzanne, I have set all three custom dictionaries as "All Languages."
However, I still have the grayed out "Add to Dictionary" tab on the spell
check dialog box. On the French modes box under Word Options/Proofing, this
is set at traditional and new spelling. You only have three choices: New
spelling, traditional spelling, and traditional and new spelling. I really
do not know what this box means, and when I tried changing it earlier, it did
not make a difference as to my original question -- How do I get the "Add to
Dictionary" tab on the spell check dialog box to become active, so that I do
not have to take three or four time-consuming steps to add a word to the
custom dictionary? Can you help me with this? Thank you for your response.
Also, Suzanne, I checked the control panel and the language there is set at
English (US). There is no listing "All languages."
 
S

Suzanne S. Barnhill

It's only the custom dictionaries that have to be set for "All Languages" so
that it won't matter what the language at the insertion point is. Given that
you appear to be using Word 2007, I'm afraid I can't help further, as I have
no experience or expertise with that version.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA

Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.
 
G

Guest

Thanks anyway, Suzanne. Yes, I am using Word 2007 with the Vista OS. Is
there anyone out there who can help me with the spell check in getting the
"Add to Dictionary" tab active on the spell check dialog box? Thank you.
 
G

Guest

Hi

I had the same problem; I solved it but am not sure how - here is what I did:

went to spelling
selection option
custom dictionary
for languag e- I checked US eng only
the box was not grayed out any longer

Now I can switch to all languages or just US and the box seems to remain.

Hope that helps - I got so desperate that I started playing around and did
not take good notes.
 
C

CharlieM

I had the same problem and worked through the list of suggestions that
follow. Nothing worked. I had one Custom.dic file, it was the default and it
was set for All Languages. I finally went into the UProof folder, made a new
folder and moved everything into that holding folder, including the Exclude
files (there were 3). I then restarted Word2007, which created a new
custom.dic file (and a new exclude file). With that new empty file the Add
Word option was available. I then went back to my old custom.dic file,
copied out all the words with a text editor and inserted them in the new
custom.dic file. This one now still has the Add Word option available and it
works.
 
R

RogerR

Exactly the right answer in my case. I was having a problem with Word
thinking I had coverted to being a Frenchman and changed the setting for
Custom to English. Set it to "All Languages" and bingo, problem fixed. Now,
on Beth's advice, I tried taking the "Read Only" status off the user folder
first, I wait with baited breath to see what crisis I might have caused
myself with this.... Thanks Suzanne, Your Da' Best!
 
Ad

Advertisements

Joined
Nov 23, 2017
Messages
1
Reaction score
0
I want to add word to custom dictionaries, but the "Add to Dictionary" tab is
grayed out. I have already made sure that the option "Select from main
dictionary only" is not checked. I really need to add words to my custom
dictionaries (which I imported from an earlier version of Word). Can someone
help.
I found that using F7 to invoke the spell-checker everything works OK, but not using right-click / Spelling ... If you find the same and would like right-click to work as well then just add this macro to your Normal.dot template Visual Basic Modules (Developer / Visual Basic):

Sub ToolsSpelling()
' This intercepts the right-click Spelling... command
SendKeys "{F7}", True
End Sub

You must give the macro exactly this name.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top