Windows Installer won't load - Windows XP Pro SP2


J

jonathandunford

Hello,

For the last few weeks my Windows installer won't load.
I've been to all of the Microsoft knowledge bases, and most of the
forums that I Googled around.
I've tried most everything :
1 - Unregistering and reregistering the Installer = (msiexec /
regserver manipulation)
2 - Repairing permissions in the register.(root and local machine,
system you name it full permissions to everybody!)

3 - The gpedit.msc manipulation

4 - I reinstalled Windows twice as well as the SP2
5 - Download version 3.1 of windows Installer
6 - The changing the msi files to old and reinstalling
7 - booting as an administrator in safe mode and unregistering and
reregistering

No avail! Windows Installer starts and then stops abruptly as if I
were in safe mode with the same corresponding message.

I even did the sfc /scannow and then "msiexec /regserver" twice.

I think I've done just about everything except completely erase my HD
and start from zero!
Any ideas out there?
 
Ad

Advertisements

T

Tulgaa

if you system restore is enabled, you must restore your system
configuration for last time
 
J

jonathandunford

if you system restore is enabled, you must restore your system
configuration for last time

I did a system restore and it still doesn't work. I have a silent fail
with the Windows Installer 3.1 and even after resetting total control
permissions the HKEYS no go.
Any other ideas?
 
T

Tulgaa

if you check "windows installer" service started on windows startup
(Start -> Run ->Msconfig ->Services tab-> "Windows Installer"
checked), i have no idea.
 
J

jonathandunford

if you check "windowsinstaller" service started onwindowsstartup
(Start -> Run ->Msconfig ->Services tab-> "WindowsInstaller"
checked), i have no idea.

Of course I tried that 100 times a week ago. I suspect there may be
some conflicting files in the msi setup. That is I'm on a French
machine. If I try to use the Installer to disinstall I get a French
message, but to install it is in English and sometimes looks like it
may start in French and then switches to English. It then hangs.
I even reverted to Installer 2 and used the command prompt to try to
repair to no avail. I've repeatedly fixed the permissions and of
course have used every step listed on the numerous Microsoft help
sites.
I'm about to bite the bullet and erase the HD and do a completely
fresh install, but I would prefer to know why this basic and simple
program won't function.
 
Ad

Advertisements

J

jonathandunford

Ok I reinstalled Windows XP Pro and the SP2 fro A - Z and now of
course the Installer works fine. It's just a shame that nobody seems
to know what causes this bug, I noticed hundreds of people with the
same problem on various forums on the www.
I think Microsoft should address this issue...
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top