Windows Defender Failed to Initialize



Running Vista Home Premium. When starting the OS, I get an error message
from Windows Defender:

"Application failed to initialize: 0x800106ba. A problem caused Windows
Defender service to stop. To start the service, restart your computer or
Help and Support on how to start the service manually."

Attempting to manually start the service brought up another error:

"Windows could not start the Windows Defender service on Local Computer.
Error 0x80092003: An error occurred while reading or writing to a file."

I have uninstalled my third-party (McAfee) security suite so Defender is all
I have on this machine.

I found similar reports on various newsgroups but no solution, workaround or
fix offered.

Any suggestions?



Thanks, Engel! This looked right, but doesn’t seem to apply to Vista.
Running appwiz.cpl, Windows Defender doesn't even show up on the list of
installed Program and Features, nor under Windows features to turn on or off.
It is also not listed in the Windows Installer CleanUp utility
( And when I try to reinstall from, as the KB article
instructs, I get the message “You do not need to install this software
because Windows Defender is included in Windows Vista. You can access
Windows Defender from the Security section of the Windows Control Panel.â€

Windows Security Center shows (under “Malware protectionâ€) that Windows
Defender is turned off. “Turn on now†churns for a while, then says,
“Security Center can’t turn on Windows Defender. Please try again later.â€

Any other ideas?


Hi Nevet. You might try this. Go to the main Windows Update window and
click on "Installed Updates" (on the left-hand side of the window, at the
bottom), and then remove "Update for Microsoft Windows (KB931099)" (only).
Reboot. Reboot again. Go back to Windows Update, and re-install the same
update, by clicking on the Check for Updates button.

This should essentially re-install Windows Defender on Vista.


hi nevet, I am having the same problems and was wondering if you figure out
the solution. i have try all the suggestion with no luck.


You could try this.

Go to Control Panel (Classic View) > Windows Update. Click on Change
Settings. Choose "Never check for updates (not recommended)". Un-check the
box under "Recommended updates". Click on Okay. Close Windows Update.

Go to Control Panel (Classic View) > Windows Firewall. Click on Change
Settings. Choose "Off (not recommended)". (Apply, OK). Close Windows

Try starting Windows Defender (Start Menu\Programs). If it starts, click on
the down-arrow to the right of the Help icon, and choose "Check for
updates". Let Defender check and download the update.

If Defender does not open, or if it opens, but doesn't download the update,
go to

Under "Latest Definition Updates", choose your operating system type, 32-bit
or 64-bit, and try the manual download. Note here the instructions
pertinent to Vista:

Hoping this works, but either way, re-enable Windows Firewall and put your
Windows Update settings back the way they were.


It would be nice and also customary to include ( append ) the fix that was
successful so that others can benefit.
That is the underlining principle of this and other newsgroup...... mutual
It is not a one on one forum.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question