Why There is IE warning about this page?


J

Jack

Hello,
I am using IE 7.
When I access this web page from the Internet:
http://www.phonedialerpro.com/options_help.htm
this page is displayed normally without any warnings.

However, when this page resides on my c drive IE gives me the following
warning:
"
To help protect your security, Internet Explorer has restricted this webpage
from running scripts or ActiveX controls that could access your computer.
Click here for more options....
"
This is my own htm page I wrote to include with my program. There are not
any java scripts not ActiveX components.
Why do I have that IE warning and what should I do to that page (not to
Windows) not to have that IE warning?

Your comments appreciated,
Jack
 
Ad

Advertisements

J

Jack

I have removed all html code and saved it.
IE still displays the same warning!!!!
I have other htm files on my computer (even with the java script) and IE
does not bother with the warning.
Why it is so?
Jack
 
J

Jack

It is not so obvious as it seems.
I have found often not logic behind MS news naming convention, haven't you?
Jack
 
C

C A Upsdell

Jack said:
Hello,
I am using IE 7.
When I access this web page from the Internet:
http://www.phonedialerpro.com/options_help.htm
this page is displayed normally without any warnings.

However, when this page resides on my c drive IE gives me the following
warning:
"
To help protect your security, Internet Explorer has restricted this webpage
from running scripts or ActiveX controls that could access your computer.
Click here for more options....

This is an IE security feature. To enable JS on your local files, do
Tools, Internet Options, Advanced, and go down to the checkbox labelled
"Allow active content to run in files on My Computer". Check it. You
will have to then close IE and reopen it for this to take effect.

(This BTW is not an IE7 issue, as it also applies to IE6 SP2.)
 
J

Jack

I do not have any active content in that file.
Also, my IE opens other htm files on my hard drive without warning.
Jack
 
Ad

Advertisements

C

C A Upsdell

I do not have any active content in that file.
Also, my IE opens other htm files on my hard drive without warning.

Very odd. The next step, I think, is to make the page validate: it
could be that IE is confused by errors in the code. Add a DOCTYPE that
will result in good compliance with the standards, fix the errors, and
see what happens next.
 
J

Jack

When I delete all htm code and save the page at 0 length I have the same
problem!
so validate is not the solution.
Deleting all the html text leaves the file title with the extention htm
only. I have tried to rename the file but it does not change anything.
I would not pursue that matter if the ALL htm files on my computer had the
same IE warning. But they do not!!!
Even that file in question:
When accessed from Internet = no IE warning
accessed from my hard drive = IE warning
Any thoughts on that?
Jack
 
C

C A Upsdell

When I delete all htm code and save the page at 0 length I have the same
problem!
so validate is not the solution.
Deleting all the html text leaves the file title with the extention htm
only. I have tried to rename the file but it does not change anything.
I would not pursue that matter if the ALL htm files on my computer had the
same IE warning. But they do not!!!
Even that file in question:
When accessed from Internet = no IE warning
accessed from my hard drive = IE warning
Any thoughts on that?

I saved the page to my HD and did not get an error message when I opened
it with IE. What you have observed therefore is inexplicable to me.
 
P

Poprivet

Jack,
You might want to check your Security settings: Local, intranet, internet,
etc. Control Panel; Internet Options; Security tab. You could have a
setting there causing it; local vs internet, most likely.

If you're using ICS it could be a firewall problem but wouldn't be if you
are running stand-alone with no LAN (intranet).

HTH
Pop`
 
J

Jack

Security settings will apply to ALL htm pages.
In my case one page opens with the warning, another one without it.!!!!
Both pages do not contain any java scripts, activeX etc.
Jack
 
Ad

Advertisements

R

Robert Aldwinckle

Jack said:
Security settings will apply to ALL htm pages.
In my case one page opens with the warning, another one without it.!!!!
Both pages do not contain any java scripts, activeX etc.
Jack


What security zone was showing in the IE Status bar then?

Try using "Mark of the web" (aka MOTW) instead?
That will put the content in the Internet zone instead of the
Local Machine zone.

Alternatively it might be interesting to see if checking

Allow active content to run in files on My Computer*

(in Internet Options, Advanced tab, Security section)

would change your symptom. E.g. that would disable
LocalMachine_LockDown which may be the reason
(e.g. security/obscurity) for your symptom.


Good luck

Robert Aldwinckle
---
 
J

Jack

If you meam by the settings shown on the bottom of the page it says:
'My Computer' and that page displays warning, but the same page accessed
from Internet displays 'Internet' at the bottom and does not have that
warning!!!!
Jack
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top