USB with old printer


Steven Gibbs

I'm trying to connect my elderly, but fully-functional, CanonBJ-10sx printer
to a new computer that came without a parallel port. I've purchased a
parallel-USB cable and that connects fine. Plug-and-play worked. The
drivers worked. However, the printer prints garbage.

I put the printer into hex-dump mode, and it looks as though it is losing
characters. (The file starts 1B 40 1B 74 ... and the printer showed 1B 40
74 ... etc. (using Epson emulation for historical reasons, but it's the same
with Canon mode).) Presumably the USB connection is too fast. Googling, I
haven't found anyone else having this problem. Does anyone have any ideas?
(Windows XP Home SP3)



You may be able to change the parallel protocol between the adapter and the
The printer you have is fairly slow, and may have handshake timeout

Alan Morris [MSFT]

when the USB to LPT cables first came out Canon made a statement that they
were not supported for many of their devices. Contact Canon and verify the
classification of support for your device in this configuration.

Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:

This posting is provided "AS IS" with no warranties, and confers no rights.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question