USB mouse driver not installing properly


B

Brad

USB mouse quit working; tried another (2) USB mice and it gets recognized by
the port but the drivers don't get installed properly; here's the error
message:


Windows encountered a problem installing the driver software for your
device.

Windows found driver software for your device but encountered an error
trying to install it.

USB Browser Mouse

An error occurred during the installation of the device.

The driver installation file for this device is missing a necessary entry.
This may be because the INF was written for Windows95 or later. Contact your
hardware vendor.

If you know the manufacturer of your device, you can visit its website and
check the support section for driver software.


Both test mice work perfectly in another Pc (desktop) with WinXPpro.

This is a Compaq Presario CQ50 laptop with Windows Vista Basic Sp2 32bit
Intel Celeron 575 2GHz, 2gig ram

Brad
 
Ad

Advertisements

B

Brad

I found a solution to my problem after having a little more time to spend
searching for the problem.

Solution:

When the problem occurs (faulty or non-installation for generic USB mice),
leave it as it is and go to 'Control Panel', go to 'System and Maintenance'
and then 'Device Manager', you should see an 'unrecognised device'. Right
click and select 'update driver', select search your own computer, select
the
tick box for 'compatible devices', select 'HID-compatible mouse' and the
device will immediately start to work. Then...

When working, connect to the internet and go back to Device Manager (if you
want to sort out the USB Browser Mouse problem completely) and under 'Mice
and other pointing devices' you will see your newly installed HID compliant
mouse, right click again and select 'update driver', this time it will
search
online and re-install a non-faulty 'USB Browser Mouse' driver? (one which
somehow works this time) and it will then work well - or just leave it with
the 'HID-compatible mouse' driver (works just as well - 'HID' just being the
standard for compliant USB 'Human Interface Devices' / HID).

Here's where I found this solution for those who want some more information.
http://forums.techarena.in/vista-hardware-devices/686991.htm

Also; I found that I had to follow this procedure for each USB PORT I
plugged my mouse into.
I also upgraded the driver to the "online found" driver but there was a
popup telling I had to update my driver for this device which you'd have to
CANCEL each time you plugged your mouse in. I tried the bottom option to
'not remind me or popup again' and it uninstalled the "online driver" so I
was back to redoing this procedure.
I'm currently just using the default HID-compatible mouse and I don't get
the popups. The mouse works fine.
Brad
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top