USB Flash (Mass Storage) not seen on Citrix thin client



Hello. I've seen numerous posts about USB drives and Citrix, etc. but
I still cannot seem to find a simple solution in being able to connect
a USB flash to my citrix server and see the drive letter on a thin
client (ICA). Is this just not possible?

I have tried 3 different USB flash drives, all three which use the
Mass Storage Class driver, but I still cannot seem to see them using
an ICA connection on a Win2000 system.

My setup - Citrix Presentation server 3.0 running on a Win2000Svr and
the client is another Win2000 Svr (didn't have a Win2000Prof system to
use, does it matter?). The drive is mapped as "D:" on the Citrix
server but after starting a new session on the client, I still cannot
see this drive.

Is this just not possible?

Someone mentioned that I should use an ICA console command to "sync"
up, but I'm not that familiar with this process. Any help on doing it
this way?

Any help or suggestions would be appreciated.

(e-mail address removed)



The first of all, what type of thin client do you use ?
For my experience, I have tried USB flash drive on a ChipPC thin client, and
it work very well.
Do you enable USB storage in your Thin client configuration (locally) ?
Have you mask drives with GPO on your server ?

Best Regards.

Steve Perry

Try mapping the driver to letter S or U, something that further up the

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question