Unable to Connect 2nd PC with MN 500 Router



I've been using MN-500 Microsoft Router with Windows XP Pro. When I upgraded
to Vista Ultimate, the settings stayed within the router since I was able to
connect to it using the #1 of 4 Ethernet Connection port and login to it's
main page: However, after upgrading to Vista, I am unable to
connect other pc's using the other 3 connections. There is nowhere within
the router itself to disable any of the 4 ethernet connections, and I am
wondering whether Vista doesn't permit me to connect my laptop.

Are there any settings that need to apply in Vista so I can use the
remaining ethernet connections of my router?

My main PC is Vista Ult. connected via Cable > Router: Ethernet connection
#1 > PC.
My laptop is Windows XP Pro and I'm trying to connect it via ethernet with
any of remaining 3 ethernet connections on the MN-500.
Since I'm able to connect to the internet and I'm able to go into the
router's settings via, should I still install the MSBN software?
So far the only option that requires the software is to upgrade the router's
firmware, but I had already installed the latest firmware for my router when
I had XP Pro.

Thanks in advance.

Rick Rogers


There's nothing in Vista that would cause the router to not allow
connections on the other channels. That configuration data is in the router
itself, it's not controlled by Windows. Make sure it is set for dynamic
addressing (DHCP) and that security features like defining access by mac
address are not turned on at this point.

Have you checked that the Vista machine will connect on any port? If it will
not, then there is a problem with the router.

Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP

Windows help - www.rickrogers.org
My thoughts http://rick-mvp.blogspot.com

Gary Tsang

Are you sure you haven't gone out of your way to disable DHCP on computers
you are trying to connect to the other 3 ports?

If you plugged whatever is plugged into port 1 into another port, you'll
likely find that it still works. That would definitely indicate that it is
an issue on the computers you are trying to connect.

Gary Tsang

Microsoft MVP - Windows Media Center


It was down to the wiring.
I originally had a very long network cable that was in two pieces connected
together with a network coupler.
I decided to shorten the cable since I didn't need it to be so long and
disconnected from the coupler.
The connection didn't work with one cable, however when I made the cable
longer with the coupler, network connection was up and running again. I
think the coupler made the wire cross cable(forgot types of network cables)
and now its works as a charm.

Thanks for your input tho.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question