U3 Flash Drive doesn't work



I have a compaq presario, WinXP (sp2) fully patched.
I can plug in most flash drives into any usb port, and they
work fine.

I have a printer and an external floppy plugged into USB ports
and they work fine.

I just bought a Sandisk 2GB U3 Titanium flash drive.
It does not work. It doesn't show up in (control panel - computer management
disk management). I thought something happened to my computer, but I
plugged in several
old sandisk titanium flash drives and they work fine.

I plugged the new U3 2GB titanium flash drive into another old dell
computer, and it worked fine.
Why do other flash drives work fine in my computer, but the new U3 Flash
drive does not.
And the new U3 Flash drive does work in a old dell computer.

I went to the HP website, and they had an article that said to uninstall
all of the
usb hub controllers. I did, now no flash drives work. I tried to
reinstall the usb hub controller,
but the found new hardware wizard could not find drivers for it.

Completely Lost,



Here is Sandisks reponse,
I thought I would post it so others could benefit.


Thank you for contacting SanDisk Technical Support.

U3 Flashdrives require more power than standard flashdrives, especially
if of higher capacities.

If the flashdrive works on other computers, please try the USB ports in
the back (if you have a desktop) as they supply more power than the ones
in the front.
Also, if you have a self-powered USB hub connected to your computer,
please try plugging the flashdrive into one of the USB ports in the hub.

U3 flashdrives may also conflict with some disc-burning programs and /
or antivirus-firewall programs.

Please check if you have Nero installed with the InCD portion of Nero
burning software. If so, please remove it as follows:

1) Go to Nero 7 in your programs list and choose Nero Product setup.
2) Next choose Modify your Nero product.
3) On the next screen click "Next" and then choose "Modify".
4) Now choose the language and click "Next".
5) Finally scroll down and find InCD, right click on it and choose "This
feature will not be available", click "Next" and then install.

These programs also conflict with U3:

- B's Clip (from BHA)
- Data Add 2.0 (Ulead)
- DirectCD (from Adaptec/Roxio)
- InCD and Nero 7.0
- PacketCD (from CeQuadrat)
- RecordNow MAX, MyCD, PrimoCD, PrimoDVD and DLA (from Veritas)
- Write DVD! (from Software Architects).

Please check under add/remove programs if you have any of the above

There may also be a drive letter conflict with another drive or network

If you do not wish to use U3, it can be removed and eventually
re-installed afterwards. After removing the U3 software, your flashdrive
may work on the computers where it's having compatibility issues.
To remove U3, the U3 software needs to be updated, because the updated
software has a REMOVE U3 option.

To remove U3:

Plug in Cruzer with U3
Click on U3 launchpad in task bar
Click on "status & settings"
Click on "U3 Launchpad Settings"
Select "Check for updates"
You will be prompted to "install launchpad", click ok

Click on U3 launchpad in task bar
Click on "status & settings
Now you should have an option tittled "remove"
Once you click on this the U3 willbe removed.
If for any reason you would like to reinstall it, you can do so at the
following link:


If you have any further questions, please feel free to reply to this
e-mail or contact our technical support department at one of the numbers

Have a Great Day and thank you for choosing SanDisk!

Alessandro D.
Sandisk Technical support
US +1 (866) 726 3475
Italy +39 (02) 696 827 25
UK +44 (207) 3654 193

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question