Two fine, except for Remote Assistance...long story.


Homer J. Simpson

Hi all,

I'm going to be rather exhaustive in the description of my current problem.
I don't think I should be skipping any of the details.

I work from home and VPN into our office. My ISP ships customers modems
(Siemens SpeedStream 4200 in my case) configured in such a way that you're
pretty much blocked from anything but fairly basic surfing. The modem
itself, as configured by the ISP, doesn't provide an awful lot of
options--at least nothing to let VPN traffic through--so after a couple of
days of trial and error and accessing hidden configuration pages, I've
managed to reconfigure it. The modem is now setup in bridge mode, rather
than router mode (or whatever the correct terminology--I'm not a networking
expert). Before reconfiguring this, my router showed an external IP address
of 192.168.x.x instead of an actual external IP address...which prevented
me from getting VPN to work. With the modem reconfigured, now my router
sees a "proper" external IP address. Hopefully this is the last I have to
say about the modem.

The VPN router, provided by my employer, is a Linksys WRV54G. I set it up
in its admin pages (Setup/Basic setup/Internet Connection Type) to use PPPoE
and provided my ISP's username/password (since those aren't provided by the
modem anymore). I've also enabled its Local DHCP Server function, so that's
the device assigning (local) addresses to all my machines. As much as
possible, I'd *really* rather not touch this router, as it took me forever
to get VPN this point, messing up my VPN settings would mean

Previously, before I had a need for VPN, I had a Linksys WRT54G, which
worked great for general internet connection sharing among all of my home
machines... The WRV54G's wireless setup however is problematic at
best--whereas the WRT54G's wireless connections were rock-solid and I had
great range, the first week I started using the WRV, all my systems
accessing it wirelessly constantly dropped connections, and the range seemed
to be a lot more limited. The office IT guy won't support any VPN setup
other than what can be done with the WRV54G they provided me with.

I figured I'd try disabling the WRV's wireless entirely, and un-retire the
WRT. The WRT is now wired up to one of the WRV's ports, the WRV's wireless
is disabled, and the WRT's wireless is enabled. The WRT's Internet
Connection Type (under Setup/Basic Setup) has been set to DHCP (as opposed
to PPPoE on the WRV), and its DHCP Server has been disabled (since that's
handled by the WRV--no point in getting two DHCP servers going and possibly
fighting each other).

As convoluted as it may sound, I've been using this setup for quite a number
of months, and it's been working great.

Recently I've had a need to use Remote Assistance (or, rather, friends and
relatives have needed my help). This is something that I hadn't done in a
number of months...and, as you might guess, it took me this long to realize
that Remote Assistance hasn't worked since I added the WRV router to my
network setup. When I only had the WRT, I didn't have any problem
connecting to other people's machines with Remote Assistance.

As it stands, when I try to answer other people's Remote Assistance requests
(using Messenger), I get some generic "connection has been terminated"
message shortly after it tries to establish the connection, without offering
much help. My XP firewall settings haven't changed. Just for testing, I
tried forwarding port 3389 (on both routers) to the actual machine
(Applications & Gaming/Port Range Forward)...something I've never had to do
previously when I only had the WRT router, so I had doubts I had a need now.
Regardless, that didn't help.

If I take a cable and bypass both routers (I hook up a system directly to
the modem), and setup a PPPoE connection using XP's networking applet (since
the modem isn't configured to provide the username/password anymore), Remote
Assistance works--which pretty much indicates for sure that something's
getting blocked or not being forwarded correctly by one of the routers.
This is where my network knowledge starts to break down...

What should I be looking for at this point?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question