System crash on full backup to WD external drive


E

Ed

Hi, all. I posed this question to Western Digital's support people, but they
were of absolutely no assistance, essentially blowing me off and blaming
Microsoft.

I have a WD MyBook 1TB external hard drive. It's a replacement for a LaCie
drive that I broke accidentally. Because I broke my LaCie, which held all my
backups, I need to do a full system backup so I have one on file. (I'm
running Windows Vista Business SP1 on a Compaq Presario laptop. I've tried
this both before and after SP1 and have got the same result.)

The weekly file-only backups I have scheduled with Windows Backup work fine.
It's only the full system backup that gives me problems. Everything goes as
planned: I select the MyBook as the destination, and Windows starts the
backup.

Once it gets near the end (I'd say about 90% done according to the status
bar), I get the blue crash screen. Here's what it says:

DRIVER_IRQL_NOT_LESS_OR_EQUAL
Stop: 0X000000D1 (0X00000004, 0X00000002, 0X00000001, 0C807503FF)
nvstor.sys - Address 807503FF base at 8074C000, DateStamp 458d543d

It doesn't restart after that, it just sticks on the blue screen. I have to
shut the computer off and then turn it back on to do anything.

Can anyone clue me in on what might be going on?

I thought maybe my driver was out of date, but Windows Update can't find a
newer one, neither can it when I go into the device's properties. Unless I'm
missing something there, or it's something other than a driver issue.

Thanks
 
Ad

Advertisements

C

Colin Barnhorst

I suggest you download a trial copy of Acronis True Image Home and see if
you get the same things. If you do bail out of the MyBook. WD MyBooks have
been problematical for some Vista testers and users all the way back to
Vista beta 1 in mid 2005.

If you have external eSATA ports on your computer consider an external
enclosure with an eSATA port and take advantage of the much faster transfer
rate.
 
B

Bender

I have successfully done a full backup onto a WD MyBook 1TB external hard
drive, using the eSata port. The backup was around 300GB and took around
half an hour, if I remember correctly.
I use the device now to record TV shows with Media Centre on my computer
that only supports the USB port.
I have never had any errors with the device.
 
B

bullinmd

Ed,

I seem to have the same problem using Windows Vista Ultimate 64 on my HP
Pavilion dv9420us using a WD 250GB "passport" USB external hard drive.

I suspect the problem may not be with Western Digital but with NVIDIA
because your driver file nvstor.sys in the "blue screen of death" you are
getting is similar to the driver file I am using when I get the "blue screen
of death": nvstor64.sys.

The "nv" at the beginning of the driver file name "tips off" the culprit
behind the problem (nv meaning NVIDIA).

I'm going to look further into this and confirm a hypothesis of mine.
 
Ad

Advertisements

B

bullinmd

Ed,

Here is what I found out:

1. You CANNOT use "safe mode" to force Windows to use the default display
driver and then use the Windows backups. Windows backups are disabled in
"safe mode".

2. GOOD NEWS! Without going to "safe mode", you can disable the display
adapter via Device Manager and then attempt the complete backup. For my
laptop, disabling the NVIDIA adapter forces Windows to use the default
display drivers.

What I would suggest you do is this:

1. Without going to "safe mode", go to Device Manager and disable the
NVIDIA adapter listed under "Display Adapters". This should force Windows to
use the default display drivers.

2. Ensure the "Aero" interface is off. When you disable the NVIDIA
drivers, "Aero" should be off. You can tell this as all windows will NOT
have that "transparent" look.

3. Perform the complete backup.

4. When all goes well, re-enable your NVIDIA display adapter via Device
Manager and check and see if "Aero" is back if you had it on before disabling
the NVIDIA drivers. You may have to change some of the display properties if
"Aero" isn't re-enabled.

I believe what happened was the complete backup attempted to back up one of
the NVIDIA drivers and it appears all graphics operations that needed that
driver were not "locked out" from using that driver until the backup of that
driver was complete. When that driver file was backed up, the operations
needing that driver should have THEN be able to access it.

In my case, for the complete PC backup, I was backing up about 115 GB across
2 hard drives (about 85 GB on C: and about 30 GB on D:). My problem came
about when the backup was 70-80% complete. I suspect the backup was
attempting to backup the NVIDIA driver that was loaded into Windows.

NOTE: My NVIDIA driver files were NVIDIA files supplied by HP.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top