Static IP on a printer fails


Joined
Oct 19, 2005
Messages
87
Reaction score
16
Guys, I'm not very technically minded so please bear with me. My Plusnet router seems to change the IP of my Kyocera FS-C5250DN colour printer on a regular basis. My B&W HPLaserjet never has this problem and is stable in that respect. Restarting the router which we have to do sometimes does not affect the HP only the Kyocera.
So I went into the settings of the Kyocera in Firefox (Mac) and turned off the Auto IP and clicked Manual. I entered the current IP of the printer of 192.168.1.17 and then the Subnet Mask of 255.255.255.0 and Default Gateway of 192.168.1.254 (the router address) plus the domain name. I also entered the Primary DNS of 192.168.1.254. And I restarted the router as advised.
Is it relevant that the printer always displays its IP as: 192.168.001.017 not 192.168.1.17 with extra zeros?

This all seems to be correct so why am I getting an error code on the Kyocera's panel? Have I missed something? Do you think the Chinese have given it coronavirus over 5G?
 

Attachments

Ad

Advertisements

Ian

Administrator
Joined
Feb 23, 2002
Messages
19,381
Reaction score
1,182
What's the error that the Kyocera admin panel gives you? It looks to be configured ok to me.

I sometimes find it easier giving a static IP address out via the router, rather than the device itself (it makes it easier to track conflicts). Is that possible with the Plusnet router?

If you set the printer back to auto IP and try the following (I think this should work with the plusnet router):
  1. Load the Plusnet router admin panel
  2. Go to the advanced settings
  3. Go to Home Network
  4. Find your device (it must be connected, matching its current IP if it doesn't have a name)
  5. Click on the Name/MAC/IP link
  6. You can now choose "Always Use This IP option" and change the default IP if required
 
Joined
Oct 19, 2005
Messages
87
Reaction score
16
I think the error code was F040
Really appreciate your reply Ian thanks. In between starting this thread and today, I have removed the Plusnet router and Netgear extenders and replaced them with a Netgear Orbi mesh system. I'll come back on this once I've had another attempt with the new router. Appreciate it thanks.
 

Ian

Administrator
Joined
Feb 23, 2002
Messages
19,381
Reaction score
1,182
What I'd try is setting the printer IP address back to default (i.e. auto-ip) etc... and then go on to your Orbi and see if there's a way to "reserve" an IP address for the printer. That will effectively do the same thing, but from the router end.

I can't remember how to do this on Orbi, as it's been a while since I had mine - but it will likely be similar to this:


The "F040" error is Kyocera specific and I can't find much information on it, other than trying to update the firmware on the printer.
 
Joined
Oct 19, 2005
Messages
87
Reaction score
16
Very helpful Ian thank you. Using this Netgear link, once in the Lan setup a list of connected devices show up with radio buttons so and I just clicked on the printer and Added it with Mac address as well. Although the printer has been restarted it's still showing Auto IP, so we'll see from here. Appreciate your help.

EDIT : That actually seems to have worked, by reserving the IP on the router and then on the printer turning off Auto IP. Result, time for a gin. Thanks Ian.
 
Last edited:
  • Like
Reactions: Ian
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

static ip addresses 1
Static 4
Anti-static 14
Static Wrist Strap 3
Anti Static DIY !! 0
TCP-IP Printing absent when I try and install Printer 1
Lost IP address? 12
Anti static strap and network cabling 2

Top