spoolsv.exe application Error that just will not go away



I upgraded my laptop (running XP pro) to service pack 3 and installed a new
printer. Since then I've been getting the error:
Spoolsv.exe - application error
The instruction at "0x00000000" referenced memory at "0x00000000". The
memory could not be "written".

This happens on boot and if you try to start the print spooler under
"services". As well as this error, at boot time, I get 3 more errors about
components of spool failing (directly after the first error).

I've tried a lot to sort it out - everything has failed Things I have tried
(in rough order)
0) run my virus checker - nothing found
1) uninstaled the printer using the manufacture's uninstall (printer =cannon
2) delete the printer driver by hand
3) use regedt32 to delete the entries for the cannon printer under the key
HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Control/Print/Environments/Windows NT
4) Uninstalled/reinstalled service pack 3
5) Tried using system restore to take me back to a week ago (this came up
with a message of system restore failed nothing has been changed).
6) Went in by hand and replaced spoolsv.exe in the system32 directory
(modified 4/13/2008 8:12pm) with the one from the i386 directory (modified
6/10/2005 7:53pm) At this time for good measure I wrote over spoolsv.exe in
c:\WINDOWS\ServicePackFiles\i386 and
c:\WINDOWS\SoftwareDistribution\Download\65cb.... both of which had the
4/13/2008 modification date. Although I managed to get all versions of this
file that came up in a search of spool on C: not to have the modification
date 4/13/2008 I still could not get rid of the error and on boot I notice
the version in the system32 directory has a modification date of 4/13/2008

I'm out of ideas for now so is anyone else having this problem and have they
solved it - I would really like to print....

I can post the error reports if it helps.


Thanks Mark - but no luck there either - in fact I could not even follow
through the instructions in the article you pointed me at. When you try and
do anything in Printers and Faxes you get the message: "Operation could not
be completed. The print spooler service is not running". trying to start
the print server fails with the same error message as before. I also looked
around to see if the spool directory exists (I'm logged on as an
administrator) and I could see a spool directory with a number of sub
directories under the system32 directory but I've no idea if that is the
default location.



Mark L. Ferguson

One of the 'dependencies' for the print spooler service is the Dcom stuff.
This again point at some Permissions error in the Registry. I would reset
that to defaults.
Aaron Stebner's WebLog Solving setup errors by using the SubInACL tool to
repair file and registry permissions:
Was this helpful? Then click the Ratings button. Voting helps the web
Mark L. Ferguson

pcbutts1 [MS MVP]

When you delete the spoolsv.exe you also have to delete the associated .dll
file spoolss.dll. Delete both of those then reboot they will automatically
be replaced on reboot.


Newsgroup Trolls. Read about mine here http://www.pcbutts1.com/downloads
The list grows. Leythos the stalker http://www.leythosthestalker.com, David
H. Lipman, Max M Wachtell III aka What's in a Name?, Fitz, Beauregard T.
Shagnasty,Rhonda Lea Kirk, Meat Plow, F Kwatu F, George Orwell


as far as I can figure out the same file and the same error just keeps
coming back - I renamed spoolsv.exe spoolss.dll winspool.exe and winspool.drv
and copied the same programs from my reinstalation CD into the system 32
directory (and everywhere else I could find them - but still no luck - in
fact things seemed a little worse this time. I do not know what regenerates
these things but it is doing a good job.

As for permissions in the register - nothing much was up there - the SAC and
DAI entries were not popular with Mark's script but from what I could see not
much else happens and I still get errors on boot.


pcbutts1 said:
The second link solved the problem although the instructions here are very
harsh. I found a second machine with the same problem (the same printer had
been installed) and this time I removed only the drivers that came with that
printer and also only the reg entries that were to to with a canon3200
printer - and had the same result without having to reinstall the drivers for
the other printers - not sure which way was quickest.

Thanks for the help :)

Bob - Fort Worth

I am working on a similar problem using XP Porfessional SR-3.
When I delete spoolsv.exe and spoolss.dll in any sequence:
(.dll then .exe, . exe then .dll, both .dll and .exe together)

Both are replaced immediately ( I don't have to reboot.)
Is this normal? or do I have some other kind of problem? I have NEVER seen
deleted items re-install themselves!

The Real Truth MVP

Yes that is normal.

Ignore posts made by the person called Leythos, he is a stalker who's been
obsessed with me for years ever since I spurned his advances towards me.

Bob - Fort Worth

Where does the system go to retrieve the "replacement" process?
I can narrow the search by checking the Date Modified but I'm finding
several possible locations.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question